aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 23afec7950..c5cae6de45 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2837,6 +2837,34 @@ PNG, PostScript, PDF, and SVG file output.")
(define-public python2-cairocffi
(package-with-python2 python-cairocffi))
+(define-public python-decorator
+ (package
+ (name "python-decorator")
+ (version "3.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/d/decorator/decorator-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0i2bnlkh0p9gs76hb28mafandcrig2fmv56w9ai6mshxwqn0083k"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; no test target
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pypi.python.org/pypi/decorator/")
+ (synopsis "Python module to simplify usage of decorators")
+ (description
+ "The aim of the decorator module is to simplify the usage of decorators
+for the average programmer, and to popularize decorators usage giving examples
+of useful decorators, such as memoize, tracing, redirecting_stdout, locked,
+etc. The core of this module is a decorator factory.")
+ (license license:expat)))
+
+(define-public python2-decorator
+ (package-with-python2 python-decorator))
+
(define-public python-ipython
(package
(name "python-ipython")
@@ -3307,6 +3335,35 @@ interfaces in an easy and portable manner.")
(define-public python2-netifaces
(package-with-python2 python-netifaces))
+(define-public python-networkx
+ (package
+ (name "python-networkx")
+ (version "1.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/networkx/networkx-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0n8wy0yq1kmdq4wh68mlhwhkndvwzx48lg41a1z0sxxms0wfp033"))))
+ (build-system python-build-system)
+ ;; python-decorator is needed at runtime
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-nose" ,python-nose)))
+ (home-page "http://networkx.github.io/")
+ (synopsis "Python module for creating and manipulating graphs and networks")
+ (description
+ "NetworkX is a Python package for the creation, manipulation, and study
+of the structure, dynamics, and functions of complex networks.")
+ (license bsd-3)))
+
+(define-public python2-networkx
+ (package-with-python2 python-networkx))
+
(define-public snakemake
(package
(name "snakemake")