aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd10f304c8..f2ea90ad09 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1078,6 +1078,25 @@ names for 256 color terminal setups.")
as functions or string constants to form colored terminal output.")
(license license:expat)))
+(define-public python-colorthief
+ (package
+ (name "python-colorthief")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "colorthief" version))
+ (sha256
+ (base32 "08bjsmmkihyksms2vgndslln02rvw56lkxz28d39qrnxbg4v1707"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pillow))
+ (home-page "https://github.com/fengsp/color-thief-py")
+ (synopsis "Grab the color palette of an image")
+ (description
+ "This package provides methods to determine the dominant color
+of an image, as well as constructing a representative color palette.")
+ (license license:bsd-3)))
+
(define-public python-construct-classes
(package
(name "python-construct-classes")