aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm60
1 files changed, 53 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b8e8097c7b..385426671e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -139,6 +139,7 @@
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;; Copyright © 2023 Ontje Lünsdorf <ontje.luensdorf@dlr.de>
+;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8940,6 +8941,53 @@ converting, and viewing many of the proprietary file formats used to store
experimental data and metadata at the Laboratory for Fluorescence Dynamics.")
(license license:bsd-3)))
+(define-public python-ffmpeg-python
+ ;; The latest release (0.2.0) is old and its test suite crashs on Python 3.10.
+ (let ((commit "df129c7ba30aaa9ffffb81a48f53aa7253b0b4e6") (revision "0"))
+ (package
+ (name "python-ffmpeg-python")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kkroening/ffmpeg-python.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zj4ac37n4igfj21zy405mdlvbpv6jyb12wfpszf8zkhhj2qby4c"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'hardcode-ffmpeg
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define ffmpeg (search-input-file inputs "bin/ffmpeg"))
+ (substitute* "ffmpeg/_run.py"
+ (("cmd='ffmpeg'")
+ (string-append "cmd='" ffmpeg "'")))
+ (substitute* "ffmpeg/tests/test_ffmpeg.py"
+ (("out_file.compile\\(\\) == \\['ffmpeg'")
+ (string-append "out_file.compile() == ['" ffmpeg "'")))))
+ ;; Some tests fail with ffmpeg 5+
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv"
+ "-k" "not test_pipe and not test__probe")))))))
+ (inputs (list ffmpeg))
+ (propagated-inputs (list python-future))
+ (native-inputs (list python-future python-numpy python-pytest
+ python-pytest-mock python-pytest-runner))
+ (home-page "https://github.com/kkroening/ffmpeg-python")
+ (synopsis "Python bindings for FFmpeg with complex filtering support")
+ (description
+ "ffmpeg-python allows you to write FFmpeg filtergraphs in familiar
+Python terms, taking care of running ffmpeg with the correct command-line
+arguments. It handles arbitrarily large (directed-acyclic) signal graphs.")
+ (license license:asl2.0))))
+
(define-public python-imageio-ffmpeg
(package
(name "python-imageio-ffmpeg")
@@ -14197,13 +14245,13 @@ implementations of ASN.1-based codecs and protocols.")
(define-public python-asn1tools
(package
(name "python-asn1tools")
- (version "0.158.0")
+ (version "0.166.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asn1tools" version))
(sha256
- (base32 "1k88a1azmyvp2ab6qcf2i40dig5abhyn7cmlyhmwwh8kr3syvma0"))))
+ (base32 "1hragm8dsm10rlyz67xslj01bycprlnimdmq1i2acns6kl6difpn"))))
(build-system python-build-system)
(propagated-inputs
(list python-bitstruct python-diskcache python-prompt-toolkit
@@ -23251,17 +23299,15 @@ Git.")
(define-public python-setuptools-rust
(package
(name "python-setuptools-rust")
- (version "1.1.2")
+ (version "1.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "setuptools-rust" version))
(sha256
- (base32 "1lb57qx1azklgzmalflq960agvwci4bwddw0zvlc9zy00fsvkbd0"))))
- (build-system python-build-system)
+ (base32 "0qi274r0fcnvxa8vs8vyhcknnzhq8pd0ig5zk1wmjc63x96p6vn8"))))
+ (build-system pyproject-build-system)
(arguments '(#:tests? #f)) ;no tests
- (native-inputs
- (list python-setuptools-scm))
(propagated-inputs
(list python-semantic-version python-typing-extensions))
(home-page "https://github.com/PyO3/setuptools-rust")