aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9dd963e396..b350c61963 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33505,6 +33505,13 @@ and frame grabber interface.")
(("^(CMAKE_DEFAULT_EXECUTABLE = ).*" _ head)
(format #f "~a ~s~%" head
(search-input-file inputs "bin/cmake"))))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Some tests try to access the network before being skipped.
+ ;; Skip them by default.
+ (substitute* "tests/test_setup.py"
+ (("pytest\\.mark\\.skipif\\(not is_site_reachable.*")
+ "pytest.mark.isolated()\n"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?