aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm47
1 files changed, 46 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 58d127277c..073243b63d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -76,7 +76,8 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
- #:use-module (guix build-system python))
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject))
(define-public python-scipy
(package
@@ -1687,6 +1688,50 @@ Out-of-Core DataFrames (similar to Pandas), to visualize and explore big
tabular datasets. This package provides the core modules of Vaex.")
(license license:expat)))
+(define-public python-pylems
+ (package
+ (name "python-pylems")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyLEMS" version))
+ (sha256
+ (base32
+ "074azbyivjbwi61fs5p8z9n6d8nk8xw6fmln1www13z1dccb3740"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-lxml))
+ (home-page "https://github.com/LEMS/pylems")
+ (synopsis
+ "Python support for the Low Entropy Model Specification language (LEMS)")
+ (description
+ "A LEMS simulator written in Python which can be used to run
+NeuroML2 models.")
+ (license license:lgpl3)))
+
+(define-public python-libneuroml
+ (package
+ (name "python-libneuroml")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NeuralEnsemble/libNeuroML.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mrm4rd6x1sm6hkvhk20mkqp9q53sl3lbvq6hqzyymkw1iqq6bhy"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-lxml python-six))
+ (native-inputs (list python-pytest python-numpy python-tables))
+ (home-page "https://libneuroml.readthedocs.org/en/latest/")
+ (synopsis
+ "Python library for working with NeuroML descriptions of neuronal models")
+ (description
+ "This package provides a Python library for working with NeuroML descriptions of
+neuronal models")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar