aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c0a1c4794f..e3f3b05ccd 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1025,7 +1025,7 @@ Mathematics (GLM) library to Python.")
"009jrlk7kmazrd3nkl217cl3x5ddg7kw9mqdgq1z9knv5h1rm8qv"))
;; Delete bundled copy of python-versioneer.
(snippet '(delete-file "versioneer.py"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -1056,6 +1056,11 @@ Mathematics (GLM) library to Python.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
+ (substitute* "setup.cfg"
+ (("ignore:There is no current event loop:DeprecationWarning" m)
+ (string-append m "
+ ignore:clear_current is deprecated:DeprecationWarning
+ ignore:make_current is deprecated.*:DeprecationWarning")))
(setenv "DISABLE_IPV6" "1")
;; The integration tests are all problematic to some
;; degree. They either require network access or some
@@ -1174,6 +1179,12 @@ Mathematics (GLM) library to Python.")
" and not test_version"
" and not test_git_revision"
+ ;; These fail because the exception text format
+ ;; appears to have changed.
+ " and not test_exception_text"
+ " and not test_worker_bad_args"
+ " and not test_run_spec_deserialize_fail"
+
;; Recursion stack failure. No idea what they
;; expected to happen.
" and not test_stack_overflow"