#!/bin/sh # GNU Guix --- Functional package management for GNU # Copyright © 2012, 2013, 2014, 2015, 2017 Ludovic Courtès # # This file is part of GNU Guix. # # GNU Guix is free software; you can redistribute it and/or modify it # under the terms of the GNU General Public License as published by # the Free Software Foundation; either version 3 of the License, or (at # your option) any later version. # # GNU Guix is distributed in the hope that it will be useful, but # WITHOUT ANY WARRANTY; without even the implied warranty of # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the # GNU General Public License for more details. # # You should have received a copy of the GNU General Public License # along with GNU Guix. If not, see . # Usage: ./pre-inst-env COMMAND ARG... # # Run COMMAND in a pre-installation environment. Typical use is # "./pre-inst-env guix build hello". # By default we may end up with absolute directory names that contain '..', # which get into $GUI
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-compression.scm')
-rw-r--r--gnu/packages/python-compression.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 4e26158b6d..d7c7d6e9b2 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -96,6 +96,24 @@ were a single file.")
Jump conversion filter by CFFI for Python.")
(license license:lgpl2.1+)))
+(define-public python-brotlicffi
+ (package
+ (name "python-brotlicffi")
+ (version "1.0.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "brotlicffi" version))
+ (sha256
+ (base32
+ "15kxgdiqcg0cm6h5xq3vkbhw7674673hcx3n2yicd3wx29l8l90c"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi))
+ (home-page "https://github.com/python-hyper/brotlicffi")
+ (synopsis "Python CFFI bindings to the Brotli library")
+ (description "This package provides Python CFFI bindings to the Brotli
+library.")
+ (license license:expat)))
+
(define-public python-isal
(package
(name "python-isal")