aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 95e10e6381..d3f8520732 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -151,3 +151,43 @@ of the project to ensure it renders properly.")
"This package provides a pytest plugin for efficiently checking PEP8
compliance.")
(license license:bsd-3)))
+
+(define-public python-pytest-shutil
+ (package
+ (name "python-pytest-shutil")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-shutil" version))
+ (sha256
+ (base32
+ "0q8j0ayzmnvlraml6i977ybdq4xi096djhf30n2m1rvnvrhm45nq"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (mkdir "/tmp/bin")
+ (substitute* "tests/integration/test_cmdline_integration.py"
+ (("dirname = '/bin'")
+ "dirname = '/tmp/bin'")
+ (("bindir = os.path.realpath\\('/bin'\\)")
+ "bindir = os.path.realpath('/tmp/bin')"))
+ #t)))))
+ (propagated-inputs
+ `(("python-contextlib2" ,python-contextlib2)
+ ("python-execnet" ,python-execnet)
+ ("python-pathpy" ,python-pathpy)
+ ("python-termcolor" ,python-termcolor)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-git" ,python-setuptools-git)))
+ (home-page "https://github.com/manahl/pytest-plugins")
+ (synopsis "Assorted shell and environment tools for py.test")
+ (description
+ "This package provides assorted shell and environment tools for the
+py.test testing framework.")
+ (license license:expat)))
Have fcgiwrap log to a file....Christopher Baines 2021-04-01gnu: services: web: Cleanup whitespace....Christopher Baines 2021-02-15services: Add Agate Gemini service....Alexandru-Sergiu Marton 2021-01-17gnu: php-fpm: Ensure no duplicate group....Julien Lepiller 2020-11-14services: gmnisrv: Export procedures and service type....Alexandru-Sergiu Marton 2020-11-09services: nginx: Re-introduce server-names-hash-bucket-size....Julien Lepiller 2020-10-27services: Add gmnisrv web service....Alexandru-Sergiu Marton 2020-10-27services: hpcguix-web: Set 'XDG_CACHE_HOME' to a writable directory....Ludovic Courtès 2020-10-14services: nginx: Add lua module....Oleg Pykhalov 2020-10-14services: nginx: Fix typo in exported symbol....Lulu 2020-09-10services: php-fpm: Add 'php-ini-file' configuration....Jelle Licht 2020-08-26services: fcgiwrap: Create parent directory for unix socket....Arun Isaac 2020-07-12services: web: Do not export record type descriptors....Ludovic Courtès 2020-07-12services: mumi: Run in a UTF-8 locale....Ludovic Courtès 2020-06-25services: Add missing (ice-9 format) import....Ludovic Courtès 2020-05-13mailmap: Update entries for Nikita....nikita 2020-04-08services/web: Fix ordering of default-nginx-config....Florian Pelz 2020-04-06services/web: Add missing ungexp for mumi shepherd services....Ricardo Wurmus 2020-04-06services/web: Add default values to all mumi-configuration fields....Ricardo Wurmus 2020-04-06gnu: mumi: Update to 0.0.0-12.bb2fe92....Ricardo Wurmus 2020-03-16services/web: Export nginx-configuration-global-directives....Ricardo Wurmus 2020-03-16services: nginx: Fix broken default configuration....Tobias Geerinckx-Rice 2020-03-15services/web: nginx-configuration: Add support for global directives....Ricardo Wurmus 2020-03-15services/web: Remove empty events directive from default-nginx-config....Ricardo Wurmus 2020-03-12services: mumi-service-type: Update to latest version of mumi....Ricardo Wurmus 2020-02-09services: web: Use the Patchwork default-from-email....Christopher Baines