aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm70
1 files changed, 38 insertions, 32 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 6c77d569c3..b290e2b29a 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014, 2015, 2017, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2017 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
@@ -543,7 +543,7 @@ photographic equipment.")
libjpeg-turbo
libomp
libpng
- librsvg
+ (librsvg-for-system)
libsecret ;optional, for storing passwords
libsoup-minimal-2
libtiff
@@ -567,7 +567,8 @@ developer. It manages your digital negatives in a database, lets you view
them through a zoomable lighttable and enables you to develop raw images
and enhance them.")
;; See src/is_supported_platform.h for supported platforms.
- (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"))
+ (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"
+ "riscv64-linux"))
(properties
'((release-monitoring-url . "https://github.com/darktable-org/darktable/releases")))
(license (list license:gpl3+ ;Darktable itself
@@ -617,7 +618,7 @@ such as Batch image processing.")
(define-public entangle
(package
(name "entangle")
- (version "3.0")
+ (version "3.0") ; delete the 'build-with-meson-0.60 phase when updating
(source
(origin
(method git-fetch)
@@ -629,34 +630,39 @@ such as Batch image processing.")
(base32 "1pdmgxjdb3xlcqsaz7l8qzj5f7g7nwzhsrgid8929bm36d49cgc7"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
- (add-after 'install 'wrap-gi-python
- ;; Make GTK find files needed by plugins.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "GUIX_PYTHONPATH")))
- (wrap-program (string-append out "/bin/entangle")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
- #t)))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'build-with-meson-0.60
+ ;; Work around ‘ERROR: Function does not take positional arguments.’.
+ (lambda _
+ (substitute* "src/meson.build"
+ (("^i18n\\.merge_file.*" match)
+ (string-append match " data_dirs:")))))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))))
+ (add-after 'install 'wrap-gi-python
+ ;; Make GTK find files needed by plugins.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (python-path (getenv "GUIX_PYTHONPATH")))
+ (wrap-program (string-append #$output "/bin/entangle")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path)))))))))
(native-inputs
- `(("cmake" ,cmake)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("xmllint" ,libxml2)))
+ (list cmake
+ gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ gtk-doc
+ itstool
+ libxml2
+ perl
+ pkg-config))
(inputs
(list gdk-pixbuf
gexiv2
@@ -791,7 +797,7 @@ a complete panorama and stitch any series of overlapping pictures.")
libiptcdata
libjpeg-turbo
libpng
- librsvg
+ (librsvg-for-system)
libsigc++
libtiff
zlib))