aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm35
1 files changed, 3 insertions, 32 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 5f16deaffa..fdbcb8e1e1 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
@@ -158,7 +158,7 @@ refreshed, and more.")
(define-public colordiff
(package
(name "colordiff")
- (version "1.0.19")
+ (version "1.0.20")
(source
(origin
(method url-fetch)
@@ -167,7 +167,7 @@ refreshed, and more.")
(string-append "http://www.colordiff.org/archive/colordiff-"
version ".tar.gz")))
(sha256
- (base32 "069vzzgs7b44bmfh3ks2psrdb26s1w19gp9w4xxbgi7nhx6w3s26"))))
+ (base32 "1kbv3lsyzzrwca4v3ajpnv8q5j0h53r94lxiqgmikxmrxrxh3cp3"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -186,35 +186,6 @@ refreshed, and more.")
'syntax highlighting' for various patch formats.")
(license gpl2+)))
-(define-public patches
- (let ((commit "ef1b8a7d954b82ed4af3a08fd63d2085d19090ef"))
- (package
- (name "patches")
- (home-page "https://github.com/stefanha/patches")
- (version (string-append "0.0-1." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (sha256
- (base32
- "11rdmhv0l1s8nqb20ywmw2zqizczch2p62qf9apyx5wqgxlnjshk"))
- (file-name (string-append name "-"version "-checkout"))))
- (build-system python-build-system)
- (inputs (list python2-notmuch))
- (arguments
- `(#:tests? #f ;no "test" target
- #:python ,python-2)) ;not compatible with Python 3
- (synopsis "Patch tracking tool")
- (description
- "@code{Patches} is a patch-tracking tool initially written for the QEMU
-project. It provides commands that build a database of patches from a mailing
-list, and commands that can search that database. It allows users to track
-the status of a patch, apply patches, and search for patches---all that from
-the command-line or from Emacs via its Notmuch integration.")
- (license gpl2+))))
-
(define-public vbindiff
(package
(name "vbindiff")