aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch')
-rw-r--r--gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch b/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
new file mode 100644
index 0000000000..ea759d022b
--- /dev/null
+++ b/gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
@@ -0,0 +1,17 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Fri, 05 Jun 2020 18:37:51 +0200
+Subject: [PATCH] gnu: websocketpp: Fix build with CMake >= 3.15.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 57ed01e78..43c772d78 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -215,7 +215,7 @@
+ set (Boost_USE_MULTITHREADED TRUE)
+ set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
+
+- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
++ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
+
+ if (Boost_FOUND)
+ # Boost is a project wide global dependency.
. [arguments]: Use G-Expressions. <#:configure-flags>: Pass "-DOIIO_BUILD_TESTS=false". [inputs]: Replace openexr-2 with openexr, fmt-8 with fmt. Use package labels. Sort alphabetically. Change-Id: I7016f89c5b7c78cbc1ffeac23e5c0cefe2a8f43b Vinicius Monego 2024-04-05gnu: kokkos: Update to 4.2.01....* gnu/packages/cpp.scm (kokkos): Update to 4.2.01. Change-Id: I29df429ad8d347ba486f0a59bf1c4e2a106e51d1 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Romain GARBAGE 2024-04-03gnu: sobjectizer: Update to 5.8.2....* gnu/packages/cpp.scm (sobjectizer): Update to 5.8.2. [arguments]: Delete trailing #t. Change-Id: I639ca0a7324987534eda13e63c44ec8c7ace0139 Maxim Cournoyer 2024-04-03gnu: Add syscmdline....* gnu/packages/cpp.scm (syscmdline): New variable. Change-Id: I721b0eb5358cf41eade23c093b506b4750c53082 Maxim Cournoyer 2024-04-01gnu: magic-enum: Update to 0.9.5....* gnu/packages/cpp.scm (magic-enum): Update to 0.9.5. Change-Id: I8306d7ef69276e33f7daada895165a88bfc938ad Signed-off-by: John Kehayias <john.kehayias@protonmail.com> dan 2024-03-27gnu: Add castxml....* gnu/packages/cpp.scm (castxml): New variable. Change-Id: I11fe3bce19a1bdb1170aa81547574836a823bcb8 Ricardo Wurmus 2024-03-10gnu: gperftools: Fix build on riscv64-linux....* gnu/packages/cpp.scm(gperftools)[arguments]: When building for riscv64-linux always link with libatomic. Change-Id: I067087fffd8c142759b6d113f993c3e2ab1aef9b Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Zheng Junjie 2024-03-02gnu: Add wide-integer....* gnu/packages/cpp.scm (wide-integer): New variable. Liliana Marie Prikler 2024-03-01gnu: c2ffi: Update to 16.0.0.0....* gnu/packages/cpp.scm (c2ffi): Update to 16.0.0.0. [native-inputs, inputs]: Replace clang-12 by clang-16. Change-Id: I8b9562ea865347eafd2e098c3cf2b42611140aff Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Attila Lendvai 2024-03-01gnu: reproc: Improve package style....* gnu/packages/cpp.scm (reproc)[arguments]: Use G-expressions. <#:configure-flags>: Remove unnecessary comment. Enable CMake variable with ON rather than 1. Change-Id: Ic5e6747e7978a40d1aab66b4c3634342736c0bcf Signed-off-by: Hilton Chain <hako@ultrarare.space> Paul A. Patience 2024-03-01gnu: reproc: Enable reproc++....* gnu/packages/cpp.scm (reproc)[arguments]<#:configure-flags>: Add -DREPROC++=ON. Change-Id: I2bf6c4c45df6a1ca5569ce1cf63c42905cc336d0 Signed-off-by: Hilton Chain <hako@ultrarare.space> Paul A. Patience 2024-02-13gnu: fast-float: Update to 6.0.0....* gnu/packages/cpp.scm (fast-float): Update to 6.0.0. [arguments]: Adjust path to test files. Signed-off-by: Christopher Baines <mail@cbaines.net> David Elsing 2024-02-11gnu: google-highway: Fix tests on i686-linux....The tests are supposed to be skipped when there are problems with excess precision. * gnu/packages/cpp.scm (google-highway)[arguments]: Modify phases when building for i686-linux to conditionally patch the tests. Change-Id: I6381a8c9f65196fd1d7d4e4130d784863b634df5 Ricardo Wurmus 2024-01-28gnu: immer: Update to 0.8.1....* gnu/packages/cpp.scm (immer): Update to 0.8.1. [source]: Drop modules and snippet. [arguments]: Add #:configure-flags to disable -Werror. Liliana Marie Prikler 2024-01-24gnu: range-v3: Update to 0.12.0....* gnu/packages/cpp.scm (range-v3): Update to 0.12.0. [source]: Remove patch. * gnu/packages/patches/range-v3-build-with-gcc10.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I078937f9aff0da31ede8d472d8739e48bb775c55 Efraim Flashner 2024-01-24gnu: range-v3: Format with 'guix style'....* gnu/packages/cpp.scm (range-v3): Format with 'guix style'. Change-Id: I249443e5e5d0f7ef49e33de4f140246a862101d2 Efraim Flashner 2024-01-24gnu: range-v3: Build with newer gcc....* gnu/packages/cpp.scm (range-v3)[native-inputs]: Remove gcc-9. Change-Id: I0411d5db3e3df15c6df0a9a010d311fe1c80015c Efraim Flashner 2024-01-09gnu: Add expected-lite....* gnu/packages/cpp.scm (expected-lite): New variable. Change-Id: I5a21dd631e1f2a3c97b920efcdca69f2537b42da Maxim Cournoyer 2023-12-27gnu: google-highway: Update to 1.0.7....* gnu/packages/cpp.scm (google-highway): Update to 1.0.7. Change-Id: I8374135da8343910156709c255f144dab1554cc0 Efraim Flashner 2023-12-27gnu: google-highway: Build shared libraries....* gnu/packages/cpp.scm (google-highway)[arguments]: Add configure-flag to build shared libraries. Change-Id: Ic222dd454290742c7c964a1a5a5b7d8d7533c3e1 Efraim Flashner 2023-12-04gnu: abseil-cpp: Update to 20230802.1....* gnu/packages/cpp.scm (abseil-cpp): Update to 20230802.1. [arguments]<#:phases>: Add phase to set timezone environment variable. * gnu/packages/cpp.scm (abseil-cpp-20220623.1): Keep old version. * gnu/packages/cpp.scm (abseil-cpp-for-c++-standard): Accept package to inherit from. * gnu/packages/cpp.scm (abseil-cpp-cxxstd11, abseil-cpp-cxxstd17): Inherit from latest supported version. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I7c29e1cd980b04496000eeb038529cdc6f636cb7 Greg Hogan 2023-11-30gnu: Add mapbox-variant....* gnu/packages/cpp.scm (mapbox-variant): New variable. Change-Id: Id84b35d97d73fcf1c116ddca844bc75ada627b55 Liliana Marie Prikler 2023-11-23gnu: folly: Update to 2023.11.06.00....* gnu/packages/cpp.scm (folly): Update to 2023.11.06.00. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-11-07gnu: Add frozen....* gnu/packages/cpp.scm (frozen): New variable. Change-Id: I738dfcfa55ddb824c2186fb61484a8a3c9532b35 Maxim Cournoyer