aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch')
-rw-r--r--gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch b/gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch
deleted file mode 100644
index b90d736211..0000000000
--- a/gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Avoid ordered comparison of pointer with integer to prevent compile error
-with GCC 11.
-
-diff --git a/hotspot/src/share/vm/memory/virtualspace.cpp b/hotspot/src/share/vm/memory/virtualspace.cpp
---- a/hotspot/src/share/vm/memory/virtualspace.cpp
-+++ b/hotspot/src/share/vm/memory/virtualspace.cpp
-@@ -581,7 +581,7 @@ ReservedHeapSpace::ReservedHeapSpace(size_t size, size_t alignment, bool large)
- assert(markOopDesc::encode_pointer_as_mark(&_base[size])->decode_pointer() == &_base[size],
- "area must be distinguishable from marks for mark-sweep");
-
-- if (base() > 0) {
-+ if (base() != NULL) {
- MemTracker::record_virtual_memory_type((address)base(), mtJavaHeap);
- }
- }
-diff --git a/hotspot/src/share/vm/opto/lcm.cpp b/hotspot/src/share/vm/opto/lcm.cpp
---- a/hotspot/src/share/vm/opto/lcm.cpp
-+++ b/hotspot/src/share/vm/opto/lcm.cpp
-@@ -39,7 +39,7 @@
- // Check whether val is not-null-decoded compressed oop,
- // i.e. will grab into the base of the heap if it represents NULL.
- static bool accesses_heap_base_zone(Node *val) {
-- if (Universe::narrow_oop_base() > 0) { // Implies UseCompressedOops.
-+ if (Universe::narrow_oop_base() != NULL) { // Implies UseCompressedOops.
- if (val && val->is_Mach()) {
- if (val->as_Mach()->ideal_Opcode() == Op_DecodeN) {
- // This assumes all Decodes with TypePtr::NotNull are matched to nodes that