aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch')
-rw-r--r--gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch b/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
deleted file mode 100644
index f16daa8009..0000000000
--- a/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Source: https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/tools/build-managers/meson/allow-dirs-outside-of-prefix.patch
---- a/mesonbuild/coredata.py
-+++ b/mesonbuild/coredata.py
-@@ -506,7 +506,6 @@ class CoreData:
- return value
- if option.name.endswith('dir') and value.is_absolute() and \
- option not in BULITIN_DIR_NOPREFIX_OPTIONS:
-- # Value must be a subdir of the prefix
- # commonpath will always return a path in the native format, so we
- # must use pathlib.PurePath to do the same conversion before
- # comparing.
-@@ -518,7 +517,7 @@ class CoreData:
- try:
- value = value.relative_to(prefix)
- except ValueError:
-- raise MesonException(msg.format(option, value, prefix))
-+ pass
- if '..' in str(value):
- raise MesonException(msg.format(option, value, prefix))
- return value.as_posix()