<
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/liba52-enable-pic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/liba52-enable-pic.patch')
0 files changed, 0 insertions, 0 deletions
gnu/packages/admin.scm
@@ -1803,8 +1803,7 @@ by bandwidth they use.")
(substitute* (list "lib/App/ClusterSSH/Config.pm"
"t/15config.t")
(("xterm")
- (which "xterm")))
- #t))
+ (which "xterm")))))
(add-before 'check 'delete-failing-tests
(lambda _
;; This checks whether all code is nicely formatted. The above
@@ -1812,8 +1811,7 @@ by bandwidth they use.")
(delete-file "t/perltidy.t")
;; Update the manifest so t/manifest.t happily passes.
(substitute* "MANIFEST"
- (("t/perltidy.t\n") ""))
- #t))
+ (("t/perltidy.t\n") ""))))
(add-after 'install 'augment-library-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1838,8 +1836,7 @@ by bandwidth they use.")
"perl-try-tiny"
"perl-x11-protocol"
"perl-x11-protocol-other")))))))
- (find-files "." ".*")))
- #t))))))
+ (find-files "." ".*")))))))))
(native-inputs
(list perl-cpan-changes
perl-file-slurp
@@ -1854,7 +1851,8 @@ by bandwidth they use.")
perl-test-trap
perltidy))
(inputs
- (list perl-exception-class
+ (list bash-minimal ;for wrap-program
+ perl-exception-class
perl-sort-naturally
perl-tk
perl-try-tiny