aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-CVE-2015-7198.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-7198.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-7198.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-7198.patch b/gnu/packages/patches/icecat-CVE-2015-7198.patch
new file mode 100644
index 0000000000..2e127897bc
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-7198.patch
@@ -0,0 +1,27 @@
+From cc2a334ee16e99d376fcb49203239abf9eb2c148 Mon Sep 17 00:00:00 2001
+From: Jeff Gilbert <jgilbert@mozilla.com>
+Date: Wed, 7 Oct 2015 13:27:37 -0700
+Subject: [PATCH] Bug 1188010 - Use MOZ_RELEASE_ASSERT when failure means
+ overflow. - r=kamidphish, a=abillings
+
+---
+ dom/canvas/WebGLTexture.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/dom/canvas/WebGLTexture.cpp b/dom/canvas/WebGLTexture.cpp
+index 60afc45..d6a6ccd 100644
+--- a/dom/canvas/WebGLTexture.cpp
++++ b/dom/canvas/WebGLTexture.cpp
+@@ -651,8 +651,7 @@ WebGLTexture::EnsureNoUninitializedImageData(TexImageTarget imageTarget,
+ imageInfo.mDepth,
+ bytespertexel,
+ mContext->mPixelStoreUnpackAlignment);
+- MOZ_ASSERT(checked_byteLength.isValid()); // Should have been checked
+- // earlier.
++ MOZ_RELEASE_ASSERT(checked_byteLength.isValid()); // Should have been checked earlier.
+
+ // Infallible for now.
+ UniquePtr<uint8_t> zeros((uint8_t*)moz_xcalloc(1,
+--
+2.5.0
+