aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch')
-rw-r--r--gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch b/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
new file mode 100644
index 0000000000..4e678f7fd4
--- /dev/null
+++ b/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
@@ -0,0 +1,15 @@
+Add PATH_SUFFIXES to look inside the sub-directory `vlc` - the original statement
+only check for `vlc.h` inside the directory `include`, `bin`, etc.
+In Guix, however, `vlc.h` lies inside `/gnu/store/<hash>-vlc-x.y.z/include/vlc/vlc.h`
+
+--- a/cmake/modules/FindLIBVLC.cmake
++++ b/cmake/modules/FindLIBVLC.cmake
+@@ -29,7 +29,7 @@ FIND_PATH(LIBVLC_INCLUDE_DIR vlc/vlc.h
+ c:/msys/local/include
+ NO_DEFAULT_PATH
+ )
+-FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h)
++FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h PATH_SUFFIXES vlc)
+
+ #Put here path to custom location
+ #example: /home/user/vlc/lib etc..