aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm46
1 files changed, 43 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 17eba3da20..791b2d7df6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -174,8 +174,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "1.4.0")
- (commit "44bbfc24e4bcc48d0e3343cd3d83452721af8c36")
- (revision 7))
+ (commit "4dfdd822102690b5687acf28365ab707b68d9476")
+ (revision 10))
(package
(name "guix")
@@ -191,7 +191,7 @@
(commit commit)))
(sha256
(base32
- "08gq04pphapr3i0gzdilp8l87rpxlh2p768qrn1fw92fmw727xf7"))
+ "1p21gz2lr7iqvma1m83k2r04w201rzvk31d5kfn2qkr9l0gds4cx"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -263,6 +263,46 @@ $(prefix)/etc/openrc\n")))
(substitute* "tests/gexp.scm"
(("2\\.0") "3.0")))))
'())
+ ,@(if (system-hurd?)
+ `((add-after 'unpack 'disable-tests/hurd
+ (lambda _
+ (substitute* "Makefile.am"
+ (("tests/derivations.scm") "")
+ (("tests/grafts.scm") "")
+ (("tests/graph.scm") "")
+ (("tests/lint.scm") "")
+ (("tests/nar.scm") "")
+ (("tests/offload.scm") "")
+ (("tests/pack.scm") "")
+ (("tests/packages.scm") "")
+ (("tests/processes.scm") "")
+ (("tests/publish.scm") "")
+ (("tests/pypi.scm") "")
+ (("tests/size.scm") "")
+ (("tests/store.scm") "")
+ (("tests/substitute.scm") "")
+ (("tests/syscalls.scm") "")
+ (("tests/union.scm") "")
+ (("tests/guix-build.sh") "")
+ (("tests/guix-build-branch.sh") "")
+ (("tests/guix-hash.sh") "")
+ (("tests/guix-locate.sh") "")
+ (("tests/guix-pack.sh") "")
+ (("tests/guix-pack-relocatable.sh") "")
+ (("tests/guix-package-aliases.sh") "")
+ (("tests/guix-package-net.sh") "")
+ (("tests/guix-home.sh") "")
+ (("tests/guix-archive.sh") "")
+ (("tests/guix-environment.sh") "")
+ (("tests/guix-package.sh") "")
+ (("tests/guix-refresh.sh") "")
+ (("tests/guix-shell.sh") "")
+ (("tests/guix-shell-export-manifest.sh") "")
+ (("tests/guix-system.sh") "")
+ (("tests/guix-graph.sh") "")
+ (("tests/guix-gc.sh") "")
+ (("tests/guix-daemon.sh") "")))))
+ '())
(add-before 'build 'use-host-compressors
(lambda* (#:key inputs target #:allow-other-keys)
(when target