aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm62
1 files changed, 35 insertions, 27 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d58db17825..ffa6d5ae52 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017, 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
-;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
;;; Copyright © 2020 Hamzeh Nasajpour <h.nasajpour@pantherx.org>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Simon South <simon@simonsouth.net>
+;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,6 +117,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages nettle)
#:use-module (gnu packages openldap)
@@ -981,7 +983,7 @@ or server shell scripts with network connections.")
(define-public mbuffer
(package
(name "mbuffer")
- (version "20211018")
+ (version "20220418")
(source (origin
(method url-fetch)
(uri (string-append
@@ -989,7 +991,7 @@ or server shell scripts with network connections.")
version ".tgz"))
(sha256
(base32
- "1qxnbpyly00kml3sjan9iqg6pqacsi3yqq66x25w455cwkjc2h72"))))
+ "1iq0lcl350r7qja7yyv911aay26d0dd8n0h33mfl84gzypwh2n3f"))))
(build-system gnu-build-system)
(native-inputs
(list which))
@@ -1654,7 +1656,7 @@ round-robin fashion.")
(propagated-inputs
(list openssh)) ; used by gandi/cli/modules/iass.py
(inputs
- (list openssl python-click python-ipy python-pyyaml python-requests))
+ (list openssl python-click-7 python-ipy python-pyyaml python-requests))
(home-page "https://cli.gandi.net")
(synopsis "Command-line interface to the Gandi.net Web API")
(description
@@ -1863,19 +1865,22 @@ live network and disk I/O bandwidth monitor.")
(define-public aircrack-ng
(package
(name "aircrack-ng")
- (version "1.6")
+ (version "1.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.aircrack-ng.org/aircrack-ng-"
version ".tar.gz"))
(sha256
- (base32 "0ix2k64qg7x3w0bzdsbk1m50kcpq1ws59g3zkwiafvpwdr4gs2sg"))))
+ (base32 "1hsq1gwmafka4bahs6rc8p98yi542h9a502h64bjlygpr3ih99q5"))))
(build-system gnu-build-system)
(native-inputs
- (list autoconf automake libtool pkg-config which))
+ (list autoconf automake libtool pkg-config which
+ ;; For tests.
+ expect))
(inputs
- (list libgcrypt
+ (list `(,hwloc "lib") ; speed boost on SMP machines
+ libgcrypt
libnl
libpcap
ethtool
@@ -1894,16 +1899,14 @@ live network and disk I/O bandwidth monitor.")
;; ‘patch-shebangs’ phase has had a chance to run.
(substitute* "evalrev"
(("/bin/sh")
- (which "sh")))
- #t))
+ (which "sh")))))
(add-after 'build 'absolutize-tools
(lambda* (#:key inputs #:allow-other-keys)
(let ((ethtool (search-input-file inputs
"/sbin/ethtool")))
(substitute* "scripts/airmon-ng"
(("ethtool ")
- (string-append ethtool " ")))
- #t))))))
+ (string-append ethtool " ")))))))))
(home-page "https://www.aircrack-ng.org")
(synopsis "Assess WiFi network security")
(description
@@ -2296,14 +2299,14 @@ libproxy only have to specify which proxy to use.")
(define-public proxychains-ng
(package
(name "proxychains-ng")
- (version "4.15")
+ (version "4.16")
(source
(origin
(method url-fetch)
(uri (string-append "http://ftp.barfooze.de/pub/sabotage/tarballs/"
"proxychains-ng-" version ".tar.xz"))
(sha256
- (base32 "10ch6rmbw2lwrq1bc9w4glxkws7hvsy5ihasvzf3yg053xzsn1rj"))))
+ (base32 "04k80jbv1wcr7ccsa0qyly33syw275kvkvzyihwwqmsqk4yria9p"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -2450,7 +2453,7 @@ the bandwidth, loss, and other parameters.")
(define-public nethogs
(package
(name "nethogs")
- (version "0.8.6")
+ (version "0.8.7")
(source
(origin
(method git-fetch)
@@ -2459,7 +2462,7 @@ the bandwidth, loss, and other parameters.")
(commit (string-append "v" version))))
(hash
(content-hash
- (base32 "0sn1sdp86akwlm4r1vmkxjjl50c0xaisk91bbz57z7kcsaphxna9")
+ (base32 "10shdwvfj90lp2fxz9260342a1c2n1jbw058qy5pyq5kh3xwr9b8")
sha256))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
@@ -2619,9 +2622,6 @@ handling for most notations in use for IPv4 and IPv6 addresses and
networks.")
(license license:bsd-3)))
-(define-public python2-ipy
- (package-with-python2 python-ipy))
-
(define-public speedtest-cli
(package
(name "speedtest-cli")
@@ -4161,7 +4161,7 @@ on hub/switched networks. It is based on @acronym{ARP} packets, it will send
(define-public putty
(package
(name "putty")
- (version "0.76")
+ (version "0.77")
(source
(origin
(method url-fetch)
@@ -4170,18 +4170,26 @@ on hub/switched networks. It is based on @acronym{ARP} packets, it will send
(string-append "http://www.putty.be/" version
"/putty-" version ".tar.gz")))
(sha256
- (base32 "0gvi8phabszqksj2by5jrjmshm7bpirhgavz0dqyz1xaimxdjz2l"))))
- (build-system gnu-build-system)
+ (base32 "1rgabc447a5aa9h16krpg3x78vh5jf4l6hkbqzr4bz9qabs7d6j1"))))
+ (build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'chdir
- (lambda _
- (chdir "unix"))))))
+ (replace 'check
+ ;; As ‘documented’ in ./Buildscr and the 0.76 Makefile.in.
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "PUTTY_TESTCRYPT" "./testcrypt")
+ (invoke (string-append "../putty-" ,version
+ "/test/cryptsuite.py"))))))))
(inputs
(list gtk+))
(native-inputs
- (list pkg-config python)) ; for tests
+ (list perl
+ pkg-config
+
+ ;; For tests.
+ python))
(synopsis "Graphical @acronym{SSH, Secure SHell} and telnet client")
(description "PuTTY is a graphical text terminal client. It supports
@acronym{SSH, Secure SHell}, telnet, and raw socket connections with good