aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8e9842515c..9fd0e70afe 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1242,30 +1242,49 @@ Encryption to Gajim.")
(guix build glib-or-gtk-build-system))
#:phases
(modify-phases %standard-phases
+ ;; To be enabled in v0.3.0, for A/V support.
+ ;;(add-after 'install 'wrap
+ ;;(lambda* (#:key outputs #:allow-other-keys)
+ ;;(let* ((out (assoc-ref outputs "out"))
+ ;;(dino (string-append out "/bin/dino"))
+ ;;(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ ;;(wrap-program dino
+ ;;`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib" ,glib)
+ ;; NOTE: Commented-out lines are to be enabled in v0.3.0.
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ;for spell-check support
+ ;;("gstreamer" ,gstreamer) ;for A/V support
+ ;;("gst-plugins-base" ,gst-plugins-base)
+ ;;("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ;for emoji support
+ ;;("libcanberra" ,libcanberra) ;for sound-notification support
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
+ ("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ;;("libsrtp" ,libsrtp) ;for calls support
+ ("pango" ,pango)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("gpgme" ,gpgme)
- ("gtk+" ,gtk+)
- ("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("sqlite" ,sqlite)))
+ ;;("webrtc-audio-processing" ,webrtc-audio-processing))) ;for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
ices): Likewise. Tobias Geerinckx-Rice 2021-06-23services: cups: Fix ‘files-config’ typo/left-over....* gnu/services/cups.scm (<policy-configuration>): Substitute <files-configuration> for <files-config> in documentation. * doc/guix.texi (Printing Services): Likewise. Tobias Geerinckx-Rice 2021-06-23services: cups: Support CUPS 2.3.3op2's LogFileGroup directive....* gnu/services/cups.scm (<files-configuration>): Add a log-file-group field. * doc/guix.texi (Printing Services): Document it. Tobias Geerinckx-Rice 2021-03-10services: Prevent following symlinks during activation....This addresses a potential security issue, where a compromised service could trick the activation code in changing the permissions, owner and group of arbitrary files. However, this patch is currently only a partial fix, due to a TOCTTOU (time-of-check to time-of-use) race, which can be fixed once guile has bindings to openat and friends. Fixes: <https://lists.gnu.org/archive/html/guix-devel/2021-01/msg00388.html> * gnu/build/activation.scm: new procedure 'mkdir-p/perms'. * gnu/services/authentication.scm (%nslcd-activation, nslcd-service-type): use new procedure. * gnu/services/cups.scm (%cups-activation): likewise. * gnu/services/dbus.scm (dbus-activation): likewise. * gnu/services/dns.scm (knot-activation): likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-01-17services: cups: reuse lp from %base-groups....* gnu/services/cups.scm (%cups-accounts): Try to reuse lp from %base-groups. Leo Prikler 2021-01-10services: cups: Add brlaser extension by default....* gnu/services/cups.scm (cups-configuration): Add brlaser to the default extensions. * doc/guix.texi (Printing Services): Document it. Tobias Geerinckx-Rice 2020-11-21services: cups: Add Splix by default....* gnu/services/cups.scm (cups-configuration): Add splix to the default extensions. * doc/guix.texi (Printing Services): Document it. Tobias Geerinckx-Rice 2020-11-21gnu: Rename escpr to epson-inkjet-printer-escpr....‘escpr’ is nice and short, but everyone else calls this package ‘epson-inkjet-printer-escpr’. More importantly, so does upstream. * gnu/packages/cups.scm (escpr, epson-inkjet-printer-escpr,): Rename escpr to epson-inkjet-printer-escpr, redefining escpr as deprecated-package. Adjust all users. Tobias Geerinckx-Rice 2020-11-18services: cups: Add some extensions by default....* gnu/services/cups.scm (cups-configuration): Add some extensions by default. doc/guix.texi (Printing Services): Document the default value. Danny Milosavljevic