aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 2cc3d0415d..11682dd4a1 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -322,6 +323,31 @@ documents in the ms and man formats, LaTeX, gemini, and terminal output.")
(home-page "https://www.pell.portland.or.us/~orc/Code/discount/")
(license license:bsd-3)))
+(define-public perl-text-markdown
+ (package
+ (name "perl-text-markdown")
+ (version "1.000031")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BO/BOBTFISH/Text-Markdown-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "06y79lla8adkqhrs41xdddqjs81dcrh266b50mfbg37bxkawd4f1"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-list-moreutils
+ perl-module-install
+ perl-test-differences
+ perl-test-exception))
+ (home-page "https://metacpan.org/release/Text-Markdown")
+ (synopsis "Convert Markdown syntax to (X)HTML")
+ (description "@code{Text::Markdown} is a Perl module that provides an
+alternate implementation of the Markdown implementation by John Gruber (see
+the markdown package). It is a slower implementation, but better
+maintained.")
+ (license license:bsd-3)))
+
(define-public perl-text-markdown-discount
(package
(name "perl-text-markdown-discount")