aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 992790188a..a2a0359055 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -527,21 +527,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.11)))
-(define-public linux-libre-6.10-version "6.10.14")
-(define-public linux-libre-6.10-gnu-revision "gnu")
-(define deblob-scripts-6.10
- (linux-libre-deblob-scripts
- linux-libre-6.10-version
- linux-libre-6.10-gnu-revision
- (base32 "1j43v1z4g1f681wvna2dh9vxaz0pgni0wchbh1xhyhhfcqbm1f47")
- (base32 "0bpkqvhvaqpim0h7nbpq7sarqisi7vlnk6x1161d6if8kb8k9glr")))
-(define-public linux-libre-6.10-pristine-source
- (let ((version linux-libre-6.10-version)
- (hash (base32 "0gj2z9ax1qv59n2mld0pg2svwi28lbq92ql98vy7crynd2ybrram")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-6.10)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -669,11 +654,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-6.10-source
- (source-with-patches linux-libre-6.10-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-6.6-source
(source-with-patches linux-libre-6.6-pristine-source
(list %boot-logo-patch
@@ -800,11 +780,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.11-gnu-revision
linux-libre-6.11-source))
-(define-public linux-libre-headers-6.10
- (make-linux-libre-headers* linux-libre-6.10-version
- linux-libre-6.10-gnu-revision
- linux-libre-6.10-source))
-
(define-public linux-libre-headers-6.6
(make-linux-libre-headers* linux-libre-6.6-version
linux-libre-6.6-gnu-revision
@@ -1166,14 +1141,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
-(define-public linux-libre-6.10
- (make-linux-libre* linux-libre-6.10-version
- linux-libre-6.10-gnu-revision
- linux-libre-6.10-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-6.11
(make-linux-libre* linux-libre-6.11-version
linux-libre-6.11-gnu-revision