aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/librewolf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/librewolf.scm')
-rw-r--r--gnu/packages/librewolf.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 42d212e9f9..42bae0fbc0 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -188,7 +188,11 @@
(invoke "make" "all")
(copy-file (string-append "librewolf-" #$version
".source.tar.gz")
- #$output))))))))
+ #$output)))))
+ (patches
+ (search-patches
+ "torbrowser-compare-paths.patch"
+ "librewolf-use-system-wide-dir.patch")))))
;; Define the versions of rust needed to build librewolf, trying to match
;; upstream. See the file taskcluster/ci/toolchain/rust.yml at
@@ -705,6 +709,11 @@
rust-cbindgen-0.26
which
yasm))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ICECAT_SYSTEM_DIR")
+ (separator #f) ;single entry
+ (files '("lib/icecat")))))
(home-page "https://librewolf.net/")
(synopsis
"Custom version of Firefox, focused on privacy, security and freedom")