aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/librewolf.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-12-11 22:13:40 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-18 22:57:11 +0800
commit396eb759d4a7be6756c1460c52067d320673859f (patch)
treede1303ce4d3a03554e1adb8413fcfe3bf8e52d24 /gnu/packages/librewolf.scm
parentfdfff1079117516327196a51ff82c8f45dc4145c (diff)
downloadguix-396eb759d4a7be6756c1460c52067d320673859f.tar.gz
guix-396eb759d4a7be6756c1460c52067d320673859f.zip
gnu: librewolf: Support Guix icecat browser extensions.
* gnu/packages/patches/librewolf-use-system-wide-dir.patch: New file. * gnu/local.mk (dist_patch_DATA): Regisiter it. * gnu/packages/librewolf.scm (make-librewolf-source)[patches]: Add it along with torbrowser-compare-paths.patch. (librewolf)[native-search-paths]: Add ICECAT_SYSTEM_DIR. Change-Id: I8609d25a7e2725ad94ab257d720326639eb06778
Diffstat (limited to 'gnu/packages/librewolf.scm')
-rw-r--r--gnu/packages/librewolf.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 42d212e9f9..42bae0fbc0 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -188,7 +188,11 @@
(invoke "make" "all")
(copy-file (string-append "librewolf-" #$version
".source.tar.gz")
- #$output))))))))
+ #$output)))))
+ (patches
+ (search-patches
+ "torbrowser-compare-paths.patch"
+ "librewolf-use-system-wide-dir.patch")))))
;; Define the versions of rust needed to build librewolf, trying to match
;; upstream. See the file taskcluster/ci/toolchain/rust.yml at
@@ -705,6 +709,11 @@
rust-cbindgen-0.26
which
yasm))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ICECAT_SYSTEM_DIR")
+ (separator #f) ;single entry
+ (files '("lib/icecat")))))
(home-page "https://librewolf.net/")
(synopsis
"Custom version of Firefox, focused on privacy, security and freedom")