aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 01018f705f..eb5f137aca 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -483,6 +483,37 @@ KDE Frameworks 5 to better interact with the system.")
(home-page "https://invent.kde.org/plasma/kgamma5")
(license license:gpl2+)))
+(define-public khotkeys
+ (package
+ (name "khotkeys")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0c9i4vxiiv90dpzsd2hjwavks87cvwplkj63751z8mazax6r95as"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list kdbusaddons
+ kdoctools
+ kglobalaccel
+ ki18n
+ kcmutils
+ kio
+ ktextwidgets
+ kxmlgui
+ kdelibs4support
+ plasma-workspace
+ qtx11extras))
+ (synopsis "Trigger actions with the keyboard")
+ (description
+ "This package provides a way to trigger actions when certain keys
+are pressed.")
+ (home-page "https://invent.kde.org/plasma/khotkeys")
+ (license license:lgpl2.0)))
+
(define-public kinfocenter
(package
(name "kinfocenter")