aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm366
1 files changed, 366 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f6de56e858..32288e980b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -147,6 +147,42 @@ ANSI escape codes to another format.")
provides functions to run a few automatable checks for Julia packages.")
(license license:expat)))
+(define-public julia-arnoldimethod
+ (package
+ (name "julia-arnoldimethod")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLinearAlgebra/ArnoldiMethod.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gs7pikgdg436srxxfywpnp12ay1mf45f7z80wym92rfrjzakwh2"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-genericschur julia-staticarrays))
+ (home-page "https://github.com/JuliaLinearAlgebra/ArnoldiMethod.jl")
+ (synopsis "Implicitly Restarted Arnoldi Method, natively in Julia")
+ (description
+ "@code{ArnoldiMethod.jl} provides an iterative method to find a few
+approximate solutions to the eigenvalue problem in standard form with main
+goals:
+
+@itemize
+@item Having a native Julia implementation of the @code{eigs} function that
+performs as well as ARPACK. With native we mean that its implementation should
+be generic and support any number type. Currently the partialschur function
+does not depend on LAPACK, and removing the last remnants of direct calls to
+BLAS is in the pipeline.
+
+@item Removing the dependency of the Julia language on ARPACK. This goal was
+already achieved before the package was stable enough, since ARPACK moved to a
+separate repository @code{Arpack.jl}.
+@end itemize")
+ (license license:expat)))
+
(define-public julia-arrayinterface
(package
(name "julia-arrayinterface")
@@ -226,6 +262,36 @@ appropriate BLAS or optimised Julia linear algebra routines. This supports a
much wider class of matrix types than Julia's in-built @code{StridedArray}.")
(license license:expat)))
+(define-public julia-astrotime
+ (package
+ (name "julia-astrotime")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/AstroTime.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "032hlanan49ypqh4lwlf91pg7052c8h5sgbxqc1771b8j9srbyd2"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-measurements))
+ (propagated-inputs
+ (list julia-erfa
+ julia-earthorientation
+ julia-itemgraphs
+ julia-macrotools
+ julia-muladdmacro
+ julia-reexport))
+ (home-page "https://github.com/JuliaAstro/AstroTime.jl")
+ (synopsis "Astronomical time keeping in Julia")
+ (description "@code{AstroTime.jl} provides a high-precision, time-scale
+aware, @code{DateTime}-like data type which supports all commonly used
+astronomical time scales.")
+ (license license:expat)))
+
(define-public julia-automa
(package
(name "julia-automa")
@@ -1252,6 +1318,40 @@ both the 256 color and 24 bit true color extensions, and the different text
styles available to terminals.")
(license license:expat)))
+(define-public julia-cstparser
+ (package
+ (name "julia-cstparser")
+ (version "3.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/julia-vscode/CSTParser.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "162jpcdph26ybg7rajbvfcbpnngygybpzk5bry4c4ppda3m1dl1i"))))
+ (build-system julia-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-or-ignore-tests
+ (lambda _
+ (substitute* "test/iterate.jl"
+ (("parser.jl")
+ (string-append #$output "/share/julia/loadpath/CSTParser/test/parser.jl"))
+ (("../src")
+ (string-append #$output "/share/julia/loadpath/CSTParser/src")))
+ (substitute* "test/check_base.jl"
+ (("testset.*" all)
+ (string-append all "return\n"))))))))
+ (inputs (list julia-tokenize))
+ (home-page "https://github.com/julia-vscode/CSTParser.jl")
+ (synopsis "Parser for Julia")
+ (description "This package provides a parser for Julia code.")
+ (license license:expat)))
+
(define-public julia-csv
(package
(name "julia-csv")
@@ -1829,6 +1929,31 @@ them. Conversions and promotions are defined to allow performing operations on
combinations of dual numbers with predefined Julia numeric types.")
(license license:expat)))
+(define-public julia-earthorientation
+ (package
+ (name "julia-earthorientation")
+ (version "0.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/EarthOrientation.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fschx4qmfd83q0ymgbzqi1dl0drbh45cd7hlcbqnm9lfmw2d847"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-leapseconds
+ julia-optionaldata
+ julia-remotefiles))
+ (home-page "https://github.com/JuliaAstro/EarthOrientation.jl")
+ (synopsis "Calculate Earth orientation parameters from IERS tables in Julia")
+ (description
+ "This package provides a functionality to calculate Earth orientation parameters
+with data retrieved from @acronym{IERS, International Earth Rotation Service}.")
+ (license license:expat)))
+
(define-public julia-ellipsisnotation
(package
(name "julia-ellipsisnotation")
@@ -3051,6 +3176,33 @@ assigned its own index, which is used to retrieve the value from the
indexed images, sometimes called \"colormap images\" or \"paletted images.\"")
(license license:expat)))
+(define-public julia-inflate
+ (package
+ (name "julia-inflate")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GunnarFarneback/Inflate.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16nbl40b819yzmfqs860xbcbx8nnxm0pkvzj49qmxibv5jnsj47q"))))
+ (build-system julia-build-system)
+ (arguments
+ ;; FIXME: Tests fail hard with a lot of errors.
+ '(#:tests? #f))
+ (propagated-inputs
+ (list julia-codeczlib))
+ (home-page "https://github.com/GunnarFarneback/Inflate.jl")
+ (synopsis "Julia implementation of zlib decompression")
+ (description "Inflate provides a pure Julia implementation of zlib decompression
+functionality, with both in- memory and streaming interfaces. This covers
+decompression of the Deflate algorithm and the Zlib and Gzip wrapper formats, as
+specified in RFC 1950, RFC 1951, and RFC 1952.")
+ (license license:expat)))
+
(define-public julia-infinity
(package
(name "julia-infinity")
@@ -3378,6 +3530,31 @@ external IRs. It can be used with Julia metaprogramming tools such as
Cassette.")
(license license:expat)))
+(define-public julia-itemgraphs
+ (package
+ (name "julia-itemgraphs")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/ItemGraphs.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16w30y7s922dzp7i64wxdrafv4gy13v3rl4k1z5jkvnmnw68kygg"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-lightgraphs))
+ (home-page "https://github.com/helgee/ItemGraphs.jl")
+ (synopsis "Shortest paths between items")
+ (description
+ "ItemGraphs is a simple wrapper around LightGraphs that enables most
+common use case for graph-like data structures: with collection of items that
+are in relations between each other providing the shortest path between two
+items.")
+ (license license:expat)))
+
(define-public julia-iteratorinterfaceextensions
(package
(name "julia-iteratorinterfaceextensions")
@@ -3576,6 +3753,100 @@ equations in string literals in the Julia language.")
implementation of matrix-free methods for iterative solvers.")
(license license:expat)))
+(define-public julia-leapseconds
+ (package
+ (name "julia-leapseconds")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaTime/LeapSeconds.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13xa49dx11n7ii77rw6300h1rfl4qlq05ypsprvfmvyww81angkp"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-erfa))
+ (home-page "https://github.com/JuliaTime/LeapSeconds.jl")
+ (synopsis "Leap seconds in Julia")
+ (description
+ "@code{LeapSeconds} provides a functionality to return the difference
+between @acronym{TAI, International Atomic Time} and @acronym{UTC, Coordinated
+Universal Time} or vice versa for a given date. For dates after 1972-01-01, this
+is the number of leap seconds.")
+ (license license:expat)))
+
+(define-public julia-lightgraphs
+ (package
+ (name "julia-lightgraphs")
+ (version "1.3.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sbromberger/LightGraphs.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ygnbzx32b9ciwgg0rn5i0m33dvrb6dh3an6bnmzac1w67sy2vxq"))))
+ (build-system julia-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; FIXME: 8x tests fails adjusting for now.
+ ;; ERROR: LoadError: Some tests did not pass: 29548 passed, 0 failed,
+ ;; 8 errored, 0 broken.
+ (add-after 'unpack 'adjust-tests
+ (lambda _
+ (substitute* "test/runtests.jl"
+ ;; Got exception outside of a @test BoundsError: attempt to
+ ;; access 1-element Vector{SubString{String}} at index [2]
+ ((".*degeneracy.*") "")
+ ;; Got exception outside of a @test type DataType has no field
+ ;; mutable
+ ((".*shortestpaths.*") ""))
+ (substitute* "test/experimental/experimental.jl"
+ ;; Got exception outside of a @test type DataType has no field mutable
+ (("\"shortestpaths\",") ""))
+ (substitute* "test/linalg/runtests.jl"
+ ;; ArgumentError: Illegal buffers for SparseMatrixCSC
+ ;; construction 5 [1, 3, 5, 7, 9, 10] [1, 2, 1, 3, 2, 4, 3, 5,
+ ;; 4] [1, 1, 1, 1, 1, 1, 1, 1, 1, 1]
+ ;;
+ ;; ArgumentError: Illegal buffers for SparseMatrixCSC
+ ;; construction 5 UInt16[0x0001, 0x0003, 0x0005, 0x0007,
+ ;; 0x0009, 0x000a] UInt16[0x0001, 0x0002, 0x0001, 0x0003,
+ ;; 0x0002, 0x0004, 0x0003, 0x0005, 0x0004] [1, 1, 1, 1, 1, 1,
+ ;; 1, 1, 1, 1]
+ ;;
+ ;; ArgumentError: Illegal buffers for SparseMatrixCSC
+ ;; construction 5 Int32[1, 3, 5, 7, 9, 10] Int32[1, 2, 1, 3,
+ ;; 2, 4, 3, 5, 4] [1, 1, 1, 1, 1, 1, 1, 1, 1, 1]
+ ((".*spectral.*") ""))
+ (substitute* "test/parallel/runtests.jl"
+ ;; Got exception outside of a @test type DataType has no field
+ ;; mutable
+ ((".*shortestpaths/johnson.*") "")
+ ;; Got exception outside of a @test TaskFailedException nested
+ ;; task error: On worker 2: UndefVarError: nv not defined
+ ((".*utils.*") "")))))))
+ (propagated-inputs
+ (list julia-arnoldimethod
+ julia-datastructures
+ julia-inflate
+ julia-simpletraits))
+ (home-page "https://github.com/sbromberger/LightGraphs.jl")
+ (synopsis "Optimized graphs package for Julia")
+ (description
+ "LightGraphs offers both (a) a set of simple, concrete graph implementations --
+Graph (for undirected graphs) and DiGraph (for directed graphs), and (b) an API
+for the development of more sophisticated graph implementations under the
+AbstractGraph type.")
+ (license license:bsd-2)))
+
(define-public julia-linesearches
(package
(name "julia-linesearches")
@@ -4016,6 +4287,33 @@ aims to provide easy-to-use tools for such tasks.")
Julia, with type-driven, overloadable packing/unpacking functionality.")
(license license:expat)))
+(define-public julia-muladdmacro
+ (package
+ (name "julia-muladdmacro")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SciML/MuladdMacro.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pvmfw7f3igpwx0w8c8i40pls0wfm248b1i662wnlrkqiw56j0yq"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/SciML/MuladdMacro.jl")
+ (synopsis "Julia macro to convert expressions to use muladd calls and FMA operations")
+ (description
+ "This package provides the @code{@@muladd} macro. It automatically converts
+expressions with multiplications and additions or subtractions to calls with
+muladd which then fuse via FMA when it would increase the performance of the
+code. The @code{@@muladd} macro can be placed on code blocks and it will automatically
+find the appropriate expressions and nest muladd expressions when necessary. In
+mixed expressions summands without multiplication will be grouped together and
+evaluated first but otherwise the order of evaluation of multiplications and
+additions is not changed.")
+ (license license:expat)))
+
(define-public julia-mutablearithmetics
(package
(name "julia-mutablearithmetics")
@@ -4259,6 +4557,29 @@ optimisation rules, and tools for applying them to deeply nested models.")
JuliaNLSolvers packages.")
(license license:expat)))
+(define-public julia-optionaldata
+ (package
+ (name "julia-optionaldata")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/OptionalData.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11js258j7cz6362ijsi24nih3lx90aalf8k1n3fv6v7iqas8bz5s"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/helgee/OptionalData.jl")
+ (synopsis "Work with global data that might not be available")
+ (description
+ "This package provides the @code{@@OptionalData} macro and the corresponding
+OptData type which is a thin wrapper around a nullable value (of type @code{Union{T,
+Nothing} where T)}. It allows you to load and access globally available data at
+runtime in a type-stable way.")
+ (license license:expat)))
+
(define-public julia-orderedcollections
(package
(name "julia-orderedcollections")
@@ -4953,6 +5274,31 @@ recursive arrays like arrays of arrays.")
(description "This package provides tools to re-export modules and symbols.")
(license license:expat)))
+(define-public julia-remotefiles
+ (package
+ (name "julia-remotefiles")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/RemoteFiles.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zpklzpd4ckp7s4wbf93qmq3dyyrx4pzl41x5i9zbiskadhniqnh"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests try to download from Internet.
+ (propagated-inputs
+ (list julia-fileio julia-http))
+ (home-page "https://github.com/helgee/RemoteFiles.jl")
+ (synopsis "Download files from the Internet and keep them up-to-date")
+ (description
+ "This package provides a functionality of files download with cURL, wget or
+@code{HTTP.jl} backends.")
+ (license license:expat)))
+
(define-public julia-referencetests
(package
(name "julia-referencetests")
@@ -5928,6 +6274,26 @@ standard named test images and example images for the internal usage in
package.")
(license license:expat)))
+(define-public julia-tokenize
+ (package
+ (name "julia-tokenize")
+ (version "0.5.24")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLang/Tokenize.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l3dy6nad0viavzy26lfnhzpd3gcxgaq7yvm7h1ja280xsh60p3i"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaGPU/Tokenize.jl")
+ (synopsis "Tokenize a string or buffer containing Julia code")
+ (description "This package takes a string or buffer containing Julia code,
+performs lexical analysis and returns a stream of tokens.")
+ (license license:expat)))
+
(define-public julia-tracker
(package
(name "julia-tracker")