aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jemalloc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/jemalloc.scm')
-rw-r--r--gnu/packages/jemalloc.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 2e25780257..354f07a838 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -75,7 +75,7 @@ fragmentation avoidance and scalable concurrency support.")
(define-public jemalloc
(package
(inherit jemalloc-4.5.0)
- (version "5.2.1")
+ (version "5.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -83,7 +83,7 @@ fragmentation avoidance and scalable concurrency support.")
version "/jemalloc-" version ".tar.bz2"))
(sha256
(base32
- "1xl7z0vwbn5iycg7amka9jd6hxd8nmfk7nahi4p9w2bnw9f0wcrl"))))
+ "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
(arguments
(substitute-keyword-arguments (package-arguments jemalloc-4.5.0)
;; Disable the thread local storage model in jemalloc 5 to prevent
scm (psautohint)[arguments]: Disable tests test_hashmap_no_version and test_hashmap_old_version. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2023-09-05gnu: python-skia-pathops: Update to 0.8.0.Nicolas Graves * gnu/packages/fontutils.scm (python-skia-pathops): Update to 0.8.0. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2023-07-16gnu: python-compreffor: Mark up description.Tobias Geerinckx-Rice * gnu/packages/fontutils.scm (python-compreffor)[synopsis, description]: Use @acronym{}. 2023-07-16gnu: python-compreffor: Update to 0.5.4.Tobias Geerinckx-Rice * gnu/packages/fontutils.scm (python-compreffor): Update to 0.5.4. 2023-07-16gnu: fontforge@20190801: Fix build.Tobias Geerinckx-Rice * gnu/packages/fontutils.scm (fontforge-20190801)[arguments]: Rewrite as G-expressions. 2023-07-20gnu: fontforge: Support build on the Hurd.Janneke Nieuwenhuizen * gnu/packages/patches/fontforge-hurd.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/fontutils.scm (fontforge)[arguments]: When building natively on the Hurd, add new phase 'apply-hurd-patch' and use it, and replace phase 'check' to skip two tests. 2023-07-20gnu: graphite2: Skip test on the Hurd.Janneke Nieuwenhuizen * gnu/packages/fontutils.scm (graphite2)[arguments]: When building natively on the Hurd, replace phase 'check' to set make-flags to skip "awamicmp3" test. 2023-07-14gnu: Add freetype-with-brotli.John Kehayias * gnu/packages/fontutils.scm (freetype-with-brotli): New variable. 2023-06-14gnu: Add bdf2sfd.gemmaro * gnu/packages/fontutils.scm (bdf2sfd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2023-05-07gnu: python-afdko: Update to 3.9.5.Maxim Cournoyer * gnu/packages/fontutils.scm (python-afdko): Update to 3.9.5. [source]: Remove obsolete substitutions in snippet. [arguments]: Re-instate all skipped tests in check phase. 2023-05-04gnu: psautohint: Remove unneeded dependencies.Ludovic Courtès * gnu/packages/fontutils.scm (psautohint)[native-inputs]: Remove PYTHON-FS and PYTHON-PYTEST-RANDOMLY. 2023-04-21gnu: python-cffsubr: Depend on python-afdko@3.6.1.Ludovic Courtès This removes the dependency of GNOME on Java: gnome -> font-abattis-cantarell -> ... -> openjdk Discussed at <https://lists.gnu.org/archive/html/guix-devel/2022-10/msg00226.html>. * gnu/packages/fontutils.scm (python-cffsubr)[inputs]: Switch to PYTHON-AFDKO-3.6.1. 2023-04-21gnu: python-afdko: Add version 3.6.1.Ludovic Courtès * gnu/packages/fontutils.scm (python-afdko-3.6.1): New variable. 2023-04-19gnu: python-fonttools-full: Rename to python-fonttools.Maxim Cournoyer * gnu/packages/python-xyz.scm (python-fonttools): Rename to... (python-fonttools-minimal): ... this. (python-fonttools-full): Adjust references to base package. Rename to... (python-fonttools): ... this. (python-matplotlib): * gnu/packages/fontutils.scm (python-cu2qu) [propagated-inputs]: Rename python-fonttools-full to python-fonttools. (python-ufolib2, python-defcon-bootstrap): Likewise. * gnu/packages/pdf.scm (weasyprint): Likewise. * gnu/packages/fonts.scm (font-meera-inimai) Adjust for renamed python-fonttools-minimal. * gnu/packages/fontutils.scm (python-cffsubr): Likewise. (python-compreffor, python-cu2qu, python-fontmath, python-fontpens-bootstrap) (python-fontparts-bootstrap, python-glyphsets, python-mutatormath) (python-ufoprocessor, graphite2, python-ufolib2) (python-defcon-bootstrap): Likewise. * gnu/packages/graphics.scm (python-booleanoperations): Likewise. 2023-04-14gnu: freetype: Update remove-reference-to-pkg-config phase.Maxim Cournoyer * gnu/packages/fontutils.scm (freetype) [arguments]: Use the newer remove-reference-to-pkg-config phase variant, with a small adjustment to make the target group optional. Use gexps and search-input-file. [propagated-inputs]: Update comment regarding harfbuzz. 2023-04-14Merge branch 'master' into core-updates.Maxim Cournoyer Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm 2023-04-12gnu: Add missing import in (gnu packages fontutils).Maxim Cournoyer This was erroneously not committed as part of 83397434b1. * gnu/packages/fontutils.scm: Add missing import. 2023-04-12gnu: python-afdko: Add bash-minimal to inputs.Maxim Cournoyer * gnu/packages/fontutils.scm (python-afdko) [inputs]: Add bash-minimal. 2023-04-12gnu: psautohint: Disable a failing test.Maxim Cournoyer * gnu/packages/fontutils.scm (psautohint) [build-system]: Use pyproject-build-system. [arguments]: Remove check phase override. Add #:test-flags, disabling a new test. 2023-04-12gnu: python-fontparts-bootstrap: Update to 0.11.0.Maxim Cournoyer * gnu/packages/fontutils.scm (python-fontparts-bootstrap): Update to 0.11.0. 2023-04-12gnu: python-ufo2ft: Update to 2.31.0.Maxim Cournoyer * gnu/packages/fontutils.scm (python-ufo2ft): Update to 2.31.0. [build-system]: Use pyproject-build-system. [arguments]: Delete field. 2023-04-12gnu: python-statmake: Update to 0.6.0.Maxim Cournoyer * gnu/packages/fontutils.scm (python-statmake): Update to 0.6.0. 2023-04-12gnu: python-afdko: Update to 3.9.4.Maxim Cournoyer * gnu/packages/fontutils.scm (python-afdko): Update to 3.9.4. [source]: Remove patch. [arguments]: Disable a few extra tests in the check phase override. Delete use-system-libxml2 phase. Update patch-problematic-requirements phase. * gnu/packages/patches/python-afdko-suppress-copyright-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. 2023-04-12gnu: python-fontmath: Update to 0.9.3.Maxim Cournoyer * gnu/packages/fontutils.scm (python-fontmath): Update to 0.9.3. 2023-03-09gnu: freetype: Fix cross-compilation.Ludovic Courtès Previously, the 'remove-reference-to-pkg-config' would break when cross-compiling because the "/bin/pkg-config" file would not be found. * gnu/packages/fontutils.scm (freetype)[arguments]: Add alternate 'remove-reference-to-pkg-config' phase for (%current-target-system) as true.