aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 21 insertions, 6 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index da68487b01..fe43d01332 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -651,8 +651,9 @@ the standard javac executable. The tool runs on JamVM instead of SableVM.")))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "git://git.savannah.gnu.org/classpath.git")
+ (url "https://git.savannah.gnu.org/git/classpath.git")
(commit commit)))
+ (file-name (string-append "classpath-" version "-checkout"))
(sha256
(base32
"1v2rww76ww322mpg3s12a1kkc6gkp31bm9gcxs532h0wq285fiw4"))))
@@ -4170,12 +4171,26 @@ more efficient storage-wise than an uncompressed bitmap (as implemented in the
#t))))
(build-system ant-build-system)
(arguments
- ;; FIXME: org.slf4j.NoBindingTest fails with the ominous "This code
- ;; should have never made it into slf4j-api.jar".
- `(#:tests? #f
- #:jar-name "slf4j-api.jar"
+ `(#:jar-name "slf4j-api.jar"
#:source-dir "slf4j-api/src/main"
- #:test-dir "slf4j-api/src/test"))
+ #:test-dir "slf4j-api/src/test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'regenerate-jar
+ (lambda _
+ ;; pom.xml ignores these files in the jar creation process. If we don't,
+ ;; we get the error "This code should have never made it into slf4j-api.jar"
+ (delete-file-recursively "build/classes/org/slf4j/impl")
+ (zero? (system* "jar" "-cf" "build/jar/slf4j-api.jar" "-C"
+ "build/classes" "."))))
+ (add-before 'check 'dont-test-abstract-classes
+ (lambda _
+ ;; abstract classes are not meant to be run with junit
+ (substitute* "build.xml"
+ (("<include name=\"\\*\\*/\\*Test.java\" />")
+ (string-append "<include name=\"**/*Test.java\" />"
+ "<exclude name=\"**/MultithreadedInitializationTest"
+ ".java\" />"))))))))
(inputs
`(("java-junit" ,java-junit)
("java-hamcrest-core" ,java-hamcrest-core)))