aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm79
1 files changed, 74 insertions, 5 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 46b0824c8d..11cb63a895 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1,8 +1,10 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,13 +23,18 @@
(define-module (gnu packages image)
#:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages doxygen)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages xml)
- #:use-module (gnu packages ghostscript) ;lcms
#:use-module (gnu packages xorg)
- #:use-module (gnu packages perl)
#:use-module (gnu packages zip)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -119,8 +126,8 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
used for storing image data.
Included are a library, libtiff, for reading and writing TIFF and a small
collection of tools for doing simple manipulations of TIFF images.")
- (license (license:bsd-style "file://COPYRIGHT"
- "See COPYRIGHT in the distribution."))
+ (license (license:non-copyleft "file://COPYRIGHT"
+ "See COPYRIGHT in the distribution."))
(home-page "http://www.libtiff.org/")))
(define-public libwmf
@@ -294,6 +301,25 @@ compose, and analyze GIF images.")
(home-page "http://giflib.sourceforge.net/")
(license license:x11)))
+(define-public libungif
+ (package
+ (name "libungif")
+ (version "4.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/giflib/libungif-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0cnksimmmjngdrys302ik1385sg1sj4i0gxivzldhgwd46n7x2kh"))))
+ (build-system gnu-build-system)
+ (inputs `(("perl" ,perl))) ;package ships some perl tools
+ (home-page "http://giflib.sourceforge.net/")
+ (synopsis "GIF decompression library")
+ (description
+ "libungif is the old GIF decompression library by the GIFLIB project.")
+ (license license:expat)))
+
(define-public imlib2
(package
(name "imlib2")
@@ -406,3 +432,46 @@ supplies a generic doubly-linked list and some string functions.")
graphics image formats like PNG, BMP, JPEG, TIFF and others.")
(license license:gpl2+)
(home-page "http://freeimage.sourceforge.net")))
+
+(define-public vigra
+ (package
+ (name "vigra")
+ (version "1.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hci.iwr.uni-heidelberg.de/vigra/vigra-"
+ version "-src.tar.gz"))
+ (sha256 (base32
+ "16d0jvz3k49niljg9qvvlyxxl15yk0300xkymvyznlmvn1hs7m22"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("hdf5" ,hdf5)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("python" ,python-2) ; print syntax
+ ("python2-numpy" ,python2-numpy)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("python2-nose" ,python2-nose)
+ ("python2-sphinx" ,python2-sphinx)))
+ (arguments
+ `(#:test-target "check"
+ #:configure-flags
+ (list "-Wno-dev" ; suppress developer mode with lots of warnings
+ (string-append "-DVIGRANUMPY_INSTALL_DIR="
+ (assoc-ref %outputs "out")
+ "/lib/python2.7/site-packages"))))
+ (synopsis "Computer vision library")
+ (description
+ "VIGRA stands for Vision with Generic Algorithms. It is an image
+processing and analysis library that puts its main emphasis on customizable
+algorithms and data structures. It is particularly strong for
+multi-dimensional image processing.")
+ (license license:expat)
+ (home-page "https://hci.iwr.uni-heidelberg.de/vigra")))