aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 29ec1096dc..838833fcf4 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -136,7 +136,7 @@ without requiring the source code to be rewritten.")
;; The headers and/or `guile-2.0.pc' refer to these packages, so they
;; must be propagated.
- ("bdw-gc" ,libgc-7.4)
+ ("bdw-gc" ,libgc)
("gmp" ,gmp)))
(self-native-input? #t)
@@ -175,15 +175,7 @@ without requiring the source code to be rewritten.")
(define-public guile-2.0/fixed
;; A package of Guile 2.0 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.
- (package (inherit guile-2.0)
- (location (source-properties->location (current-source-location)))
-
- ;; Keep using the stable libgc.
- (propagated-inputs (map (match-lambda
- (("bdw-gc" _)
- `("bdw-gc" ,libgc))
- (x x))
- (package-propagated-inputs guile-2.0)))))
+ guile-2.0)
;;;