aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-18 15:14:02 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-18 15:14:02 +0100
commitbda1bc6c51a3a0176d19f2b7b66e192fc7e0dc78 (patch)
treee6831e641821de459b0e9216fb1182d8803edc26 /gnu/packages/guile.scm
parent0562dbe5d3160b72856bfa7d890ec2caf4073633 (diff)
downloadguix-bda1bc6c51a3a0176d19f2b7b66e192fc7e0dc78.tar.gz
guix-bda1bc6c51a3a0176d19f2b7b66e192fc7e0dc78.zip
gnu: Make libgc 7.4 the default.
* gnu/packages/bdw-gc.scm (libgc): Rename to... (libgc-7.2): ... this. (libgc-7.4): Rename to... (libgc): ... this. * gnu/packages/guile.scm (guile-2.0): Switch to LIBGC. (guile-2.0/fixed): Alias GUILE-2.0.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 29ec1096dc..838833fcf4 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -136,7 +136,7 @@ without requiring the source code to be rewritten.")
;; The headers and/or `guile-2.0.pc' refer to these packages, so they
;; must be propagated.
- ("bdw-gc" ,libgc-7.4)
+ ("bdw-gc" ,libgc)
("gmp" ,gmp)))
(self-native-input? #t)
@@ -175,15 +175,7 @@ without requiring the source code to be rewritten.")
(define-public guile-2.0/fixed
;; A package of Guile 2.0 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.
- (package (inherit guile-2.0)
- (location (source-properties->location (current-source-location)))
-
- ;; Keep using the stable libgc.
- (propagated-inputs (map (match-lambda
- (("bdw-gc" _)
- `("bdw-gc" ,libgc))
- (x x))
- (package-propagated-inputs guile-2.0)))))
+ guile-2.0)
;;;