aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 57a4b84efe..ce0affdaea 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2196,7 +2196,11 @@ provides tight coupling to Guix.")
texinfo
gettext-minimal ;Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
help2man
- pkg-config))
+ pkg-config
+ ;; needed when cross-compiling.
+ guile-3.0
+ guile-lib
+ guile-smc))
(inputs (list guile-3.0))
(propagated-inputs (list guile-lib guile-smc guile-dsv))
(home-page "https://github.com/artyom-poptsov/guile-ics")
@@ -2213,6 +2217,11 @@ The library is shipped with documentation in Info format and usage examples.")
(package
(inherit guile-ics)
(name "guile2.2-ics")
+ (native-inputs
+ (modify-inputs (package-native-inputs guile-ics)
+ (replace "guile" guile-2.2)
+ (replace "guile-lib" guile2.2-lib)
+ (replace "guile-smc" guile2.2-smc)))
(inputs (list guile-2.2))
(propagated-inputs (list guile2.2-lib guile2.2-dsv guile2.2-smc))))
td>installer: Capture external commands output....Josselin Poiret 2022-02-02installer: Remove specific logging code....Josselin Poiret 2022-02-02installer: Keep PATH inside the install container....Josselin Poiret 2022-02-02installer: Un-export syslog syntax....Josselin Poiret 2022-02-02installer: Use new installer-log-line everywhere....Josselin Poiret 2022-02-02installer: Generalize logging facility....Josselin Poiret 2022-02-02installer: Add crash dump upload support....Mathieu Othacehe 2022-01-14installer: Install the locale before mounting the cow-store....Mathieu Othacehe 2022-01-14installer: Do not set the locale in run-command....Mathieu Othacehe 2022-01-14installer: Remove an unused procedure....Mathieu Othacehe 2022-01-14installer: Check if ci.guix.gnu.org can be reached....Mathieu Othacehe 2022-01-14installer: Ignore small devices....Mathieu Othacehe 2021-12-28installer: Offer 'gpm-service-type' for non-graphical systems....Leo Famulari 2021-12-28installer: Recommend 'ntp-service-type' for non-graphical systems....Leo Famulari 2021-12-28installer: Offer the CUPS printing service on a dedicated page....Leo Famulari