aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm68
1 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0717acf83b..8e8a73ad30 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2020 Jesse Gibbons <jgibbons2357@gmail.com>
;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
-;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
+;;; Copyright © 2020, 2021, 2022 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
@@ -43,6 +43,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1329,7 +1330,7 @@ format.")
(define-public guile-newt
(package
(name "guile-newt")
- (version "0.0.2")
+ (version "0.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1338,7 +1339,7 @@ format.")
(file-name (git-file-name name version))
(sha256
(base32
- "1gksd1lzgjjh1p9vczghg8jw995d22hm34kbsiv8rcryirv2xy09"))))
+ "0hbznqigdkyh0kdkpnkp7sz2qd0g5dvmibcdi1rki02zg78mzypv"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
@@ -1346,7 +1347,7 @@ format.")
(inputs
(list guile-3.0 newt))
(native-inputs
- (list autoconf automake pkg-config))
+ (list autoconf automake pkg-config guile-3.0))
(synopsis "Guile bindings to Newt")
(description
"This package provides bindings for Newt, a programming library for
@@ -1392,7 +1393,7 @@ microblogging service.")
(define-public guile-parted
(package
(name "guile-parted")
- (version "0.0.5")
+ (version "0.0.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1401,20 +1402,18 @@ microblogging service.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ar6n38br3h1jm54yy6d54rpqdgsy7pmnj3nqdzqrfk8z0kx0rm9"))
+ "12ygz0dw8zjr8g3z4g3sh4d1yw3fiphh0ssyqd4nllqa3sfwv21f"))
(modules '((guix build utils)))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
'("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ (list autoconf automake guile-3.0 guile-bytestructures pkg-config))
(inputs
- ;; XXX: Use Parted 3.4 to work around issues when using 3.5 in the Guix
- ;; System installer: <https://issues.guix.gnu.org/55549>.
- (list guile-3.0 parted-3.4))
+ (list guile-3.0 parted))
(propagated-inputs
(list guile-bytestructures))
- (native-inputs
- (list autoconf automake pkg-config))
(synopsis "Guile bindings to GNU Parted")
(description
"This package provides bindings for GNU Parted library, a C library
@@ -3117,32 +3116,33 @@ denote the invalidity of certain code paths in a Scheme program.")
(license license:gpl3+)))
(define-public guile-srfi-158
- (package
- (name "guile-srfi-158")
- (version "0.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
- (commit version)))
- (sha256
- (base32
- "0b8hlv1bldbcwkcxi9y8mm6xp5gbgpg7b15bwqxv70iynl9d9a7c"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (native-inputs
- (list autoconf automake pkg-config))
- (inputs
- (list guile-3.0))
- (home-page "https://gitlab.com/samplet/guile-srfi-158")
- (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
- (description "This package provides an implementation of SRFI 158
+ (let ((commit "13126d1ed37892c864337a600a43d6876625fb99")
+ (revision "0"))
+ (package
+ (name "guile-srfi-158")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0hg57l3w5qamip1clkab0q01np5nqln9y054q39smm4ki0svdl8w"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list guile-3.0 autoconf automake pkg-config))
+ (inputs (list guile-3.0))
+ (home-page "https://gitlab.com/samplet/guile-srfi-158")
+ (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
+ (description "This package provides an implementation of SRFI 158
for Guile. SRFI 158 defines utility procedures that create,
transform, and consume generators. It also defines procedures that
return accumulators. It is implemented by wrapping the sample
implementation in a thin Guile compatibility layer.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public guile-srfi-159
(let ((commit "1bd98abda2ae4ef8f36761a167903e55c6bda7bb")
@@ -3944,7 +3944,7 @@ as signed sessions, multipart message support, etc.")
(add-after 'unpack 'run-hall
(lambda _
(setenv "HOME" "/tmp") ; for ~/.hall
- (invoke "hall" "dist" "-x"))))))
+ (invoke "hall" "build-system" "-x"))))))
(native-inputs
(list autoconf
automake