aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 61e4ec7a9f..08dd73b24f 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -379,21 +379,17 @@ graphs in Graphviz's DOT language, written in pure Python.")
;; (see:
;; https://github.com/kjellmf/dot2tex/issues/94).
"-k" "not test_semicolon")))))))
- (native-inputs (list python-pytest))
+ (native-inputs
+ (list python-pytest
+ (texlive-updmap.cfg
+ (list texlive-geometry
+ texlive-pgf
+ texlive-preview
+ texlive-pstricks
+ texlive-xcolor
+ texlive-xkeyval))))
(inputs (list graphviz))
- (propagated-inputs
- (list python-pyparsing
- ;; These TeX dependencies are propagated to make it easier to build
- ;; the resulting generated TeX files, which \usepackage them.
- texlive-amsmath
- texlive-bin
- texlive-geometry
- texlive-latex-bin
- texlive-pgf
- texlive-pstricks
- texlive-preview
- texlive-xcolor
- texlive-xkeyval))
+ (propagated-inputs (list python-pyparsing))
(home-page "https://github.com/kjellmf/dot2tex")
(synopsis "Graphviz to LaTeX converter")
(description