aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index f0bbe772c9..ea6c02fc19 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -215,7 +215,15 @@ structure and layout algorithms.")
(patches (search-patches "python-uqbar-python3.10.patch"))))
(build-system pyproject-build-system)
(arguments
- (list #:test-flags '(list "tests")))
+ (list #:test-flags
+ '(list "tests"
+ "-k" (string-append
+ "not test_interpret_code_blocks_02 "
+ "and not test_find_executable "
+ "and not test_sphinx_api_1 "
+ "and not test_sphinx_book_text_cached "
+ "and not test_sphinx_book_text_uncached "
+ "and not test_sphinx_book_text_broken_strict"))))
(native-inputs
(list graphviz
python-flake8
@@ -224,8 +232,12 @@ structure and layout algorithms.")
python-pytest
python-pytest-cov))
(propagated-inputs
- (list python-black python-sphinx python-sphinx-rtd-theme
- python-unidecode))
+ (list python-black python-sphinx-5 python-unidecode
+ (package/inherit python-sphinx-rtd-theme
+ (propagated-inputs
+ (modify-inputs
+ (package-propagated-inputs python-sphinx-rtd-theme)
+ (replace "python-sphinx" python-sphinx-5))))))
(home-page "https://github.com/josiah-wolf-oberholtzer/uqbar")
(synopsis "Tools for building documentation with Sphinx, Graphviz and LaTeX")
(description