aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 2e67adab89..61a9f8a92e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -924,12 +924,19 @@ exception-handling library.")
((target-x86-32?)
#~((add-after 'unpack 'skip-faulty-test
(lambda _
- ;; This test fails on i686 when comparing floating point
- ;; values, probably due to excess precision. However,
- ;; '-fexcess-precision' is not implemented for C++ in
- ;; GCC 10 so just skip it.
(substitute* "tests/CMakeLists.txt"
- (("bezier-test") ""))))))
+ ;; This test fails on i686 when comparing floating point
+ ;; values, probably due to excess precision. However,
+ ;; '-fexcess-precision' is not implemented for C++ in
+ ;; GCC 10 so just skip it.
+ (("bezier-test") "")
+
+ ;; https://gitlab.com/inkscape/lib2geom/-/issues/68
+ (("ellipse-test") "")
+
+ ;; XXX: Additional unresolved test failures.
+ (("elliptical-arc-test") "")
+ (("self-intersections-test") ""))))))
;; See https://gitlab.com/inkscape/lib2geom/-/issues/63
((target-aarch64?)
#~((add-after 'unpack 'fix-aarch64-faulty-test