aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9a505000e3..eed7126873 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7851,49 +7851,6 @@ systems can import this package to enable running programs as services without
modifying them.")
(license license:zlib)))
-(define-public go-github-com-goccy-go-yaml
- (package
- (name "go-github-com-goccy-go-yaml")
- (version "1.11.3")
- (home-page "https://github.com/goccy/go-yaml")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1rm2rfnlvv704zkb1mnjqv5xx32vfkzv7r2kc8if6gr9ryb7hmbf"))))
- (build-system go-build-system)
- (arguments
- (list
- #:go go-1.18
- #:import-path "github.com/goccy/go-yaml"
- #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'remove-benchmarks
- (lambda* (#:key import-path #:allow-other-keys)
- (delete-file-recursively
- (string-append "src/" import-path "/benchmarks")))))))
- (propagated-inputs
- (list go-github-com-fatih-color go-golang-org-x-xerrors))
- (native-inputs
- (list go-github-com-go-playground-validator-v10
- go-github-com-google-go-cmp-cmp))
- (synopsis "YAML support for the Go language")
- (description
- "This package provides features beyond the
-@uref{https://github.com/go-yaml/yaml, defacto YAML library} including:
-
-@itemize
-@item Pretty format for error notifications
-@item Support Scanner or Lexer or Parser as public API
-@item Support Anchor and Alias to Marshaler
-@item Allow referencing elements declared in another file via anchors
-@item Extract value or AST by YAMLPath (YAMLPath is like a JSONPath)
-@end itemize")
- (license license:expat)))
-
(define-public go-github-com-tekwizely-go-parsing
(let ((commit "1548cfb17df54d365ce9febed0677c06a40a8ceb")
(revision "0"))