aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5c63c8fe17..0a67bfa23c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5940,6 +5940,18 @@ tool."))
Trace/Debug/Info/Warn/Error methods on @code{hclog.Logger} are used
correctly.")))
+(define-public go-msgio
+ (package
+ (inherit go-github-com-libp2p-go-msgio)
+ (name "go-msgio")
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:install-source? #f
+ #:import-path "github.com/libp2p/go-msgio/msgio"
+ #:unpack-path "github.com/libp2p/go-msgio"))
+ (synopsis "CLI tool to wrap messages with msgio header.")))
+
(define-public go-numcpus
(package
(inherit go-github-com-tklauser-numcpus)