aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c30a4dff34..4050a3e370 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1371,6 +1371,34 @@ language.")
found in the go-openapi toolkit.")
(license license:asl2.0)))
+(define-public go-github-com-go-openapi-jsonpointer
+ (package
+ (name "go-github-com-go-openapi-jsonpointer")
+ (version "0.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-openapi/jsonpointer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17gb0ab2r61j4gqbpwgpz6cvf9jy91xwn11gkbg3b1rq797if7vc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-openapi/jsonpointer"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-go-openapi-swag))
+ (home-page "https://github.com/go-openapi/jsonpointer")
+ (synopsis "JSON Pointer with structs")
+ (description
+ "This package provides an implementation of JSON Pointer, initially
+prototyped in @url{https://github.com/xeipuuv/gojsonpointer}.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-openapi-swag
(package
(name "go-github-com-go-openapi-swag")