aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 667ca7b217..b27e973e2e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -638,7 +638,7 @@ Gomega matcher library.")
(define-public go-github-com-onsi-gomega
(package
(name "go-github-com-onsi-gomega")
- (version "1.19.0")
+ (version "1.33.1")
(source
(origin
(method git-fetch)
@@ -647,20 +647,22 @@ Gomega matcher library.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "092phwk97sk4sv0nbx5pfhqs6x3x1lnrjwyda1m6b6zwrfmq5c6i"))))
+ (base32 "1jygwi2lz3q7ri85dxdxf187l1hm7r3i0c843l47iakivmld31x1"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/onsi/gomega"
- ;; Unless we disable the tests, we have a circular dependency on
- ;; ginkgo/v2.
- #:tests? #f))
+ (list
+ ;; Unless we disable the tests, we have a circular dependency on
+ ;; ginkgo/v2.
+ #:tests? #f
+ #:go go-1.21
+ #:import-path "github.com/onsi/gomega"))
(propagated-inputs
(list go-github-com-golang-protobuf-proto
go-golang-org-x-net
go-golang-org-x-sys
go-golang-org-x-text
go-google-golang-org-protobuf
- go-gopkg-in-yaml-v2))
+ go-gopkg-in-yaml-v3))
(home-page "https://github.com/onsi/gomega")
(synopsis "Matcher library for Ginkgo")
(description