aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c887da7003..69e870adf8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -384,7 +384,6 @@ services.")
(define-public libcloudproviders
(package/inherit libcloudproviders-minimal
(name "libcloudproviders")
- (version "0.3.1")
(outputs (cons "doc" (package-outputs libcloudproviders-minimal)))
(arguments
(substitute-keyword-arguments (package-arguments libcloudproviders-minimal)
@@ -567,7 +566,7 @@ in JavaScript.")
vala))
(inputs
(list avahi
- librsvg
+ (librsvg-for-system)
libgee
gst-plugins-base
gtk+))
@@ -871,7 +870,7 @@ tomorrow, the rest of the week and for special occasions.")
libjpeg-turbo
libportal
libpng
- librsvg
+ (librsvg-for-system)
python-pygobject
rest
tracker
@@ -4381,7 +4380,7 @@ engineering.")
python))
(inputs
(list bash-minimal
- librsvg
+ (librsvg-for-system)
gsettings-desktop-schemas
gtk+
pango
@@ -6734,7 +6733,7 @@ which can read a large number of file formats.")
(define-public rhythmbox
(package
(name "rhythmbox")
- (version "3.4.6")
+ (version "3.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/rhythmbox/"
@@ -6742,7 +6741,7 @@ which can read a large number of file formats.")
"rhythmbox-" version ".tar.xz"))
(sha256
(base32
- "0d5hbsdk2p8w567mfzy4kk8xn4d227hrbyy857li3r2mrq884mpr"))))
+ "0zps1k72n7yycw6djgilgdacwdi993xqh1sh9x9lr9n17z0mcv9g"))))
(build-system meson-build-system)
(arguments
(list
@@ -6802,7 +6801,7 @@ which can read a large number of file formats.")
libpeas
libsecret
libmtp
- libsoup-minimal-2
+ libsoup-minimal
libxml2
lirc
pango
@@ -9109,7 +9108,7 @@ devices using the GNOME desktop.")
libgtop
libnma
libpwquality
- librsvg ;for loading SVG files
+ (librsvg-for-system) ;for loading SVG files
libsecret
libxml2
libwacom
@@ -10987,7 +10986,7 @@ Bluefish supports many programming and markup languages.")
gtk+
gtkmm-3
libhandy
- librsvg
+ (librsvg-for-system)
libxml2
libwnck))
(home-page "https://wiki.gnome.org/Apps/SystemMonitor")
@@ -11772,7 +11771,7 @@ functionality.")
("libheif" ,libheif)
("libjpeg" ,libjpeg-turbo)
("libraw" ,libraw)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("libtiff" ,libtiff)
("libwebp" ,libwebp)))
(home-page "https://wiki.gnome.org/Apps/Gthumb")
@@ -12468,7 +12467,7 @@ to.")
("itstool" ,itstool)
("pkg-config" ,pkg-config)))
(inputs
- (list gtk+ librsvg libxml2))
+ (list gtk+ (librsvg-for-system) libxml2))
(arguments
`(#:configure-flags '("CFLAGS=-fcommon")))
(home-page "https://glabels.org/")