aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm41
1 files changed, 2 insertions, 39 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d6bf3f6227..d369e92c23 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -683,45 +683,8 @@ behavior, system tray and input source indicator for IBus.")
(license license:gpl3+)))
(define-public gnome-shell-extension-topicons-redux
- (package
- (name "gnome-shell-extension-topicons-redux")
- (version "6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/pop-planet/TopIcons-Redux.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1dli9xb545n3xlj6q4wl0y5gzkm903zs47p8fiq71pdvbr6v38rj"))))
- (build-system gnu-build-system)
- (native-inputs
- (list `(,glib "bin")))
- (arguments
- `(#:tests? #f ;no test defined in the project
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (invoke "make"
- "install"
- (string-append
- "INSTALL_PATH="
- out
- "/share/gnome-shell/extensions"))))))))
- (home-page "https://gitlab.com/pop-planet/TopIcons-Redux")
- (synopsis "Display legacy tray icons in the GNOME Shell top panel")
- (description "Many applications, such as chat clients, downloaders, and
-some media players, are meant to run long-term in the background even after you
-close their window. These applications remain accessible by adding an icon to
-the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
-3.26. TopIcons Redux brings those icons back into the top panel so that it's
-easier to keep track of applications running in the background.")
- (license license:gpl2+)))
+ (deprecated-package "gnome-shell-extension-topicons-redux"
+ gnome-shell-extension-appindicator))
(define-public gnome-shell-extension-dash-to-dock
(package