aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index c7e7394f43..21192acdd6 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -781,6 +781,70 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(define-public numix-theme
(deprecated-package "numix-theme" numix-gtk-theme))
+(define-public orchis-theme
+ (package
+ (name "orchis-theme")
+ (version "2021-02-28")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vinceliuice/Orchis-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qp3phiza93qllrjm5xjjca5b7l2sbng8c382khy9m97grxvcq0y"))
+ (modules '((guix build utils)
+ (ice-9 regex)
+ (srfi srfi-26)))
+ (snippet
+ '(begin
+ (for-each
+ (lambda (f)
+ (let* ((r (make-regexp "\\.scss"))
+ (f* (regexp-substitute #f (regexp-exec r f) 'pre ".css")))
+ (if (file-exists? f*)
+ (delete-file f*))))
+ (find-files "." ".*\\.scss"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list
+ "--dest" (string-append
+ (assoc-ref %outputs "out")
+ "/share/themes")
+ "--theme" "all"
+ "--radio-color")
+ #:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'build (lambda _ (invoke "./parse-sass.sh")))
+ (replace 'install
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (mkdir-p
+ (cadr (or (member "--dest" configure-flags)
+ (member "-d" configure-flags))))
+ (apply invoke "./install.sh" configure-flags)
+ #t)))))
+ (inputs
+ `(("gtk-engines" ,gtk-engines)))
+ (native-inputs
+ `(;("coreutils" ,coreutils)
+ ("gtk+" ,gtk+)
+ ("sassc" ,sassc)))
+ (home-page "https://github.com/vinceliuice/Orchis-theme")
+ (synopsis "Material Design theme for a wide range of environments")
+ (description "Orchis is a Material Design them for GNOME/GTK based
+desktop environments. It is based on materia-theme and adds more color
+variants.")
+ (license (list license:gpl3 ; According to COPYING.
+ license:lgpl2.1 ; Some style sheets.
+ license:cc-by-sa4.0)))) ; Some icons
+
(define-public markets
(package
(name "markets")
ested-shebangs that also handles node-gyp and other shebangs under "/lib/node_modules". [inputs]: Add Python for node-gyp as "python-for-target". (node-lts)[inputs]: Likewise. (libnode)[arguments]: Adjust to delete 'patch-nested-shebangs rather than 'patch-npm-shebang and 'patch-node-shebang. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Philip McGrath 2021-12-24gnu: node: Update to 10.24.1 for bootstrapping....* gnu/packages/node.scm (node): Update to 10.24.1. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Philip McGrath 2021-12-24gnu: node: Avoid duplicating build phases....* gnu/packages/node.scm (node)[arguments]: Split 'patch-files phase into 'patch-hardcoded-program-references and 'delete-problematic-tests. Adapt 'patch-hardcoded-program-references and 'configure to work unmodified on node-lts, but don't try to share 'delete-problematic-tests, because those details seem to change too much between node versions. (node, node-lts)[inputs]: Use bash-minimal rather than bash. (node-lts)[arguments]: Inherit 'patch-hardcoded-program-references, and 'configure phases from the bootstrap node. Remove the 'patch-files phase, keeping its remaining non-inherited work in a new 'replace-llhttp-sources phase. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Philip McGrath 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-15gnu: node-lts: Update to 14.18.1 [security fixes]....* gnu/packages/node.scm (node-lts): Update to 14.18.1. [native-inputs]: Replace c-ares with c-ares-for-node. [inputs]: Replace c-ares with c-ares-for-node. Includes fixes for CVE-2021-22918, CVE-2021-22930, CVE-2021-22931, CVE-2021-22939, and CVE-2021-22940. Jelle Licht 2021-11-15gnu: llhttp-bootstrap: Update to 2.1.4 [security-fixes]....* gnu/packages/node.scm (llhttp-bootstrap): Update to 2.1.4. Includes fixes for CVE-2021-22959 and CVE-2021-22960. Jelle Licht 2021-11-15gnu: node: Add cpe-name....* gnu/packages/node.scm (node)[properties]: Add cpe-name. Jelle Licht 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke 2021-10-13gnu: Rename google-brotli back to brotli....Sorry for the noise, but good riddance. Our nonstandard name for this package has caused confusion since it was added. For example, the duplicate python-brotli and python-google-brotli packages added later, with the latter name making even less sense. The Python packages will be fixed in the next commit. * gnu/packages/compression.scm (google-brotli): Redefine as a deprecated-package, with… (brotli): …restored to canonical status. (python-google-brotli)[inherit]: Adjust accordingly. * gnu/packages/databases.scm (apache-arrow)[inputs]: Adjust accordingly. * gnu/packages/fontutils.scm (woff2)[inputs]: Likewise. * gnu/packages/gnome.scm (libsoup)[propagated-inputs]: Likewise. * gnu/packages/networking (wireshark)[inputs]: Likewise. * gnu/packages/node.scm (node-lts)[arguments, native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-imagecodecs)[inputs]: Likewise. Tobias Geerinckx-Rice 2021-10-10gnu: llhttp: Fix build....* gnu/packages/node.scm (llhttp-bootstrap)[arguments]: Add missing keyword argument to 'configure' phase. Guillaume Le Vaillant 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-09-02gnu: node: Enable cross-compilation....Node runs parts of itself on the host for bootstraping therefore for cross-compiling support we need to fidle with the rpath in the build system, as well as duplicating some of the dependencies as native-inputs and inputs. * gnu/pakcages/node.scm (node)[arguments]: Refer to /bin/sh and /bin/env directly instead of using (which). Add new 'set-bootstrap-host-rpath phase to correctly set the rpath for binaries that are meant to run on the host. Pass --cross-compiling and --dest-cpu to configure script if needed. Set the CC_host, CXX_host, CC, CCX and PKG_CONFIG variable for cross-compilation. Refer to the host python. Do not return #t from any phases. [native-inputs]: Add c-ares, http-parser, icu4c, libuv, nghttp2, openssl and zlib. Remove which. [inputs]: Add bash and coreutils. (llhttp-bootstrap)[arguments]: Refer to esbuild via (or native-inputs inputs). (node-lts)[arguments]: Add new 'set-bootstrap-host-rpath phase to correctly set the rpath for host binaries. Pass --cross-compiling and --dest-cpu to configure script if needed. Set the CC_host, CXX_host, CCX and PKG_CONFIG variable for cross-compilation. Refer to the host python. Do not return #t from any phases. Refer to /bin/sh and /bin/env directly instead of using (which). Do not return #t from any phases. [native-inputs]: Hardcode native inputs instead of inheriting them from node. [inputs]: Add bash and coreutils. Pierre Langlois 2021-07-24gnu: Use 'search-input-file' when looking for executables....* gnu/packages/admin.scm (isc-dhcp): Use 'search-input-file' when looking for executables. * gnu/packages/audio.scm (ableton-link): Likewise. * gnu/packages/benchmark.scm (fio): Likewise. * gnu/packages/bioinformatics.scm (roary): Likewise. (ngless): Likewise. * gnu/packages/boost.scm (boost-for-irods): Likewise. * gnu/packages/bootloaders.scm (grub): Likewise. (grub-efi): Likewise. * gnu/packages/chemistry.scm (inchi): Likewise. * gnu/packages/dictionaries.scm (ding): Likewise. * gnu/packages/dlang.scm (ldc): Likewise. * gnu/packages/education.scm (childsplay): Likewise. * gnu/packages/emacs-xyz.scm (emacs-hyperbole): Likewise. (emacs-haskell-mode): Likewise. (emacs-auctex): Likewise. (emacs-ggtags): Likewise. (emacs-graphviz-dot-mode): Likewise. (emacs-flycheck-grammalecte): Likewise. (emacs-counsel-notmuch): Likewise. (emacspeak): Likewise. (emacs-exwm): Likewise. (emacs-exwm-x): Likewise. (emacs-treemacs): Likewise. (emacs-telega): Likewise. (emacs-exiftool): Likewise. * gnu/packages/emulators.scm (higan): Likewise. * gnu/packages/engineering.scm (freehdl): Likewise. (librepcb): Likewise. * gnu/packages/entr.scm (entr): Likewise. * gnu/packages/file-systems.scm (libeatmydata): Likewise. (xfstests): Likewise. (mergerfs): Likewise. (mergerfs-tools): Likewise. * gnu/packages/finance.scm (monero-gui): Likewise. * gnu/packages/flashing-tools.scm (flashrom): Likewise. * gnu/packages/fontutils.scm (fontforge): Likewise. * gnu/packages/game-development.scm (python2-renpy): Likewise. * gnu/packages/games.scm (opensurge): Likewise. (xboard): Likewise. (hyperrogue): Likewise. (flare-game): Likewise. (chessx): Likewise. * gnu/packages/geo.scm (grass): Likewise. * gnu/packages/glib.scm (glib): Likewise. * gnu/packages/gnome.scm (mm-common): Likewise. (network-manager-openvpn): Likewise. (network-manager-vpnc): Likewise. (network-manager-openconnect): Likewise. (apostrophe): Likewise. * gnu/packages/gnupg.scm (pius): Likewise. (jetring): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/golang.scm (go-1.4): Likewise. * gnu/packages/graphviz.scm (xdot): Likewise. * gnu/packages/guile-xyz.scm (jupyter-guile-kernel): Likewise. * gnu/packages/haskell-xyz.scm (ghc-hindent): Likewise. * gnu/packages/ibus.scm (ibus): Likewise. * gnu/packages/image.scm (phockup): Likewise. * gnu/packages/irc.scm (quassel): Likewise. * gnu/packages/java.scm (drip): Likewise. (ant-bootstrap): Likewise. (tla2tools): Likewise. * gnu/packages/julia.scm (julia): Likewise. * gnu/packages/less.scm (lesspipe): Likewise. * gnu/packages/libreoffice.scm (libreoffice): Likewise. * gnu/packages/linux.scm (fuse): Likewise. (lm-sensors): Likewise. (bluez): Likewise. (fakeroot): Likewise. (inputattach): Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-diskspace): Likewise. * gnu/packages/lisp.scm (lisp-repl-core-dumper): Likewise. * gnu/packages/lua.scm (fennel): Likewise. * gnu/packages/lxde.scm (spacefm): Likewise. * gnu/packages/mail.scm (public-inbox): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. (maxima): Likewise. (frama-c): Likewise. * gnu/packages/messaging.scm (libgadu): Likewise. * gnu/packages/music.scm (denemo): Likewise. (curseradio): Likewise. * gnu/packages/netpbm.scm (netpbm): Likewise. * gnu/packages/networking.scm (blueman): Likewise. (squid): Likewise. (aircrack-ng): Likewise. * gnu/packages/node.scm (node): Likewise. (node-llparse-frontend-bootstrap): Likewise. (node-llparse-bootstrap): Likewise. (llhttp-bootstrap): Likewise. (node-lts): Likewise. * gnu/packages/ocaml.scm (ocaml-4.11): Likewise. (opam): Likewise. (ocaml-graph): Likewise. * gnu/packages/orpheus.scm (orpheus): Likewise. * gnu/packages/password-utils.scm (password-store): Likewise. * gnu/packages/python.scm (pypy3): Likewise. * gnu/packages/qt.scm (qt5ct): Likewise. * gnu/packages/radio.scm (libosmo-dsp): Likewise. * gnu/packages/ruby.scm (ruby-pandoc-ruby): Likewise. * gnu/packages/rust.scm (rust-1.30): Likewise. * gnu/packages/screen.scm (byobu): Likewise. * gnu/packages/statistics.scm (r-with-tests): Likewise. * gnu/packages/suckless.scm (surf): Likewise. * gnu/packages/syndication.scm (gfeeds): Likewise. * gnu/packages/telephony.scm (mumble): Likewise. * gnu/packages/terminals.scm (alacritty): Likewise. * gnu/packages/tex.scm (texlive-bin): Likewise. * gnu/packages/uml.scm (plantuml): Likewise. * gnu/packages/version-control.scm (python-git-multimail): Likewise. (gitolite): Likewise. (hg-commitsigs): Likewise. (git-when-merged): Likewise. (git-imerge): Likewise. (gita): Likewise. * gnu/packages/video.scm (you-get): Likewise. * gnu/packages/vim.scm (eovim): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. (virt-manager): Likewise. (criu): Likewise. * gnu/packages/vpn.scm (strongswan): Likewise. (xl2tpd): Likewise. * gnu/packages/wm.scm (i3lock-fancy): Likewise. * gnu/packages/wxwidgets.scm (python-wxpython): Likewise. (python2-wxpython): Likewise. * gnu/packages/xdisorg.scm (autorandr): Likewise. * gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise. (v86d): Likewise. (mkfontdir): Likewise. (xpra): Likewise. Ludovic Courtès 2021-06-16gnu: node: Prepare for ICU 69....* gnu/packages/node.scm (node)[source](snippet): Add substitution. Marius Bakke