aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e5d3a8d943..1eb20558d4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -186,7 +186,8 @@ also known as DXTn or DXTC) for Mesa.")
("libxml2" ,libxml2)
;; TODO: Add 'libva'
;; TODO: Add 'libxml2-python' for OpenGL ES 1.1 and 2.0 support
- ("makedepend" ,makedepend)))
+ ("makedepend" ,makedepend)
+ ("s2tc" ,s2tc)))
(native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gnu-gettext)
@@ -220,7 +221,18 @@ also known as DXTn or DXTC) for Mesa.")
(lambda _
(substitute* "src/glsl/tests/lower_jumps/create_test_cases.py"
(("/usr/bin/env bash") (which "bash"))))
- %standard-phases))))
+ (alist-cons-before
+ 'build 'fix-dxtn-libname
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((s2tc (assoc-ref inputs "s2tc")))
+ ;; Remain agnostic to .so.X.Y.Z versions while doing
+ ;; the substitutions so we're future-safe.
+ (substitute*
+ '("src/gallium/auxiliary/util/u_format_s3tc.c"
+ "src/mesa/main/texcompress_s3tc.c")
+ (("\"libtxc_dxtn\\.so")
+ (string-append "\"" s2tc "/lib/libtxc_dxtn.so")))))
+ %standard-phases)))))
(home-page "http://mesa3d.org/")
(synopsis "OpenGL implementation")
(description "Mesa is a free implementation of the OpenGL specification -