aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm136
1 files changed, 66 insertions, 70 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3c32a220c4..4b5b5eefd5 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -9,9 +9,9 @@
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
-;;; Copyright © 2018-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018-2022, 2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019-2024 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
@@ -77,6 +77,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -147,7 +148,7 @@
;; <https://bitcoincore.org/en/lifecycle/#schedule>.
(package
(name "bitcoin-core")
- (version "27.0")
+ (version "27.1")
(source (origin
(method url-fetch)
(uri
@@ -155,7 +156,7 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "0sqldg540q5d4lvr8fs9sbycxgzkij5y52rqqg6blmxisd8yc7lw"))))
+ "1npk30c4s2xihm2vxmswl2x4baw5n23gsbaw5y8sx3qvjbym240c"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -296,14 +297,14 @@ Accounting.")
(define-public homebank
(package
(name "homebank")
- (version "5.7.4")
+ (version "5.8.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.gethomebank.org/public/sources"
"/homebank-" version ".tar.gz"))
(sha256
(base32
- "1r2lpf2qjvyc9l4llgy6453dn527pylvd49kr6ihrskmr1373kj2"))))
+ "00fwadn6q2hryx7q1xf5fhb5q3ywfnlb1r4xxn7yq6ilzvm5zhv0"))))
(build-system glib-or-gtk-build-system)
(native-inputs
(list pkg-config intltool))
@@ -611,7 +612,7 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(define-public electron-cash
(package
(name "electron-cash")
- (version "4.4.0")
+ (version "4.4.1")
(source
(origin
(method git-fetch)
@@ -620,7 +621,7 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1hfkp24m1yipadanjf5wm6clmyllkcbh7fbw8whnrvxa2v7sa4l8"))))
+ (base32 "11xhlssr7bvdv3p256k87y35vjzyfd93p72w8f2xy7j5jh6abhp1"))))
(build-system python-build-system)
(arguments
(list
@@ -647,7 +648,8 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(wrap-qt-program "electron-cash"
#:output out #:inputs inputs)))))))
(inputs
- (list libevent
+ (list bash-minimal
+ libevent
libsecp256k1-bitcoin-cash
openssl
python-cython
@@ -687,7 +689,7 @@ blockchain.")
;; the system's dynamically linked library.
(package
(name "monero")
- (version "0.18.3.3")
+ (version "0.18.3.4")
(source
(origin
(method git-fetch)
@@ -705,7 +707,7 @@ blockchain.")
delete-file-recursively
'("external/miniupnp" "external/rapidjson"))))
(sha256
- (base32 "1d3dnkz18v0mlspafnzm301lmdiz6pwjzdbsdq23mn7cyynzgnc9"))))
+ (base32 "0rjyxcggg7pdp5026kbb49mk7vnvldvbr7qlkn76n4sq20cpk3v9"))))
(build-system cmake-build-system)
(native-inputs
(list doxygen
@@ -754,30 +756,28 @@ blockchain.")
(lambda _
(for-each make-file-writable
(find-files "tests/data/" "wallet_9svHk1.*"))))
- ;; Only try tests that don't need access to network or system
(replace 'check
+ ;; Only try tests that don't need access to network or system
(lambda* (#:key tests? #:allow-other-keys)
;; Core tests sometimes fail, at least on i686-linux.
;; Let's disable them for now and just try hash tests
;; and unit tests.
;; (invoke "make" "ARGS=-R 'hash|core_tests' --verbose" "test")))
(when tests?
- (invoke "make" "ARGS=-R 'hash' --verbose" "test"))))
- (add-after 'check 'unit-tests
- (lambda _
- (let ((excluded-unit-tests
- (string-join
- '("AddressFromURL.Success"
- "AddressFromURL.Failure"
- "DNSResolver.IPv4Success"
- "DNSResolver.DNSSECSuccess"
- "DNSResolver.DNSSECFailure"
- "DNSResolver.GetTXTRecord"
- "is_hdd.linux_os_root")
- ":")))
- (invoke "tests/unit_tests/unit_tests"
- (string-append "--gtest_filter=-"
- excluded-unit-tests)))))
+ (invoke "make" "ARGS=-R 'hash' --verbose" "test")
+ (let ((excluded-unit-tests
+ (string-join
+ '("AddressFromURL.Success"
+ "AddressFromURL.Failure"
+ "DNSResolver.IPv4Success"
+ "DNSResolver.DNSSECSuccess"
+ "DNSResolver.DNSSECFailure"
+ "DNSResolver.GetTXTRecord"
+ "is_hdd.linux_os_root")
+ ":")))
+ (invoke "tests/unit_tests/unit_tests"
+ (string-append "--gtest_filter=-"
+ excluded-unit-tests))))))
(add-after 'install 'delete-unused-files
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively
@@ -792,7 +792,7 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.18.3.3")
+ (version "0.18.3.4")
(source
(origin
(method git-fetch)
@@ -808,7 +808,7 @@ the Monero command line client and daemon.")
;; See the 'extract-monero-sources' phase.
(delete-file-recursively "monero")))
(sha256
- (base32 "1yy98y37l5nfxj921h6rbhni6fk0fic9bs4gqbnq2n4397h7jamj"))))
+ (base32 "09x8184kbpw74qlak2x9amz7j3qkacnk9l0c1cws1d0fghlm6n9m"))))
(build-system qt-build-system)
(native-inputs
`(,@(package-native-inputs monero)
@@ -1690,9 +1690,8 @@ trezord as a regular user instead of needing to it run as root.")
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/trezor/trezord-go"
- ;; Requires go 1.18 or later: https://github.com/trezor/trezord-go/commit/f559ee5079679aeb5f897c65318d3310f78223ca
- #:go ,go-1.20))
+ `(#:go ,go-1.18
+ #:import-path "github.com/trezor/trezord-go"))
(native-inputs
(list go-github-com-gorilla-csrf
go-github-com-gorilla-handlers
@@ -1753,7 +1752,7 @@ following three utilities are included with the library:
(define-public bitcoin-unlimited
(package
(name "bitcoin-unlimited")
- (version "2.0.0.1")
+ (version "2.1.0.0")
(source
(origin
(method git-fetch)
@@ -1762,7 +1761,7 @@ following three utilities are included with the library:
(commit (string-append "BCHunlimited" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1kkmg0gp86qz3ya8y5a00yic1mals138b9fv2cjlm7683sfjjljx"))))
+ (base32 "0cny12s03wsgx8iijg5cbr7r6wif9ck7dn98hsv9sz8xq1i5vjk4"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -2078,29 +2077,25 @@ software Beancount with a focus on features and usability.")
(license license:expat)))
(define-public emacs-beancount
- ;; Note that upstream has not made any release since this project moved
- ;; into its own repository (it was originally part of beancount itself)
- (let ((commit "687775da63784d153a3c1cfee9801090c6b51842")
- (revision "1"))
- (package
- (name "emacs-beancount")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/beancount/beancount-mode")
- (commit commit)))
- (sha256
- (base32
- "08383yqqanx29al1hg1r6ndx3gwjg6fj7kl340f1zz9m9cfiyvg3"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (home-page "https://github.com/beancount/beancount-mode")
- (synopsis "Emacs mode for Beancount")
- (description
- "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-beancount")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beancount/beancount-mode")
+ (commit version)))
+ (sha256
+ (base32
+ "01ivxgv1g0pkr0xi43366pghc3j3mmhk5bshis6kkn04bq04cx7f"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/beancount/beancount-mode")
+ (synopsis "Emacs mode for Beancount")
+ (description
+ "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")
+ (license license:gpl3+)))
(define-public hledger-web
(package
@@ -2175,15 +2170,15 @@ editing on the Web.")
(define-public quantlib
(package
(name "quantlib")
- (version "1.26")
+ (version "1.34")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://github.com/lballabio/QuantLib/releases/download/QuantLib-v"
+ "https://github.com/lballabio/QuantLib/releases/download/v"
version "/QuantLib-" version ".tar.gz"))
(sha256
- (base32 "1sbk6rg51x5xpa93xmqmrj32a1l9vba51xck0017cxzblg0nrzh4"))))
+ (base32 "0l7yn9bal0csyix0ydzcfj003kma4sx7w5hyfxhh6mbnxn6am1zb"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2228,13 +2223,13 @@ interactive controls. This package provides a GTK+ graphical user interface
(define-public python-ta-lib
(package
(name "python-ta-lib")
- (version "0.4.21")
+ (version "0.4.32")
(source
(origin
(method url-fetch)
(uri (pypi-uri "TA-Lib" version))
(sha256
- (base32 "17sf222mq2vx924f15qlz5czkkq5vsnsjy9ibwkrk8lalr6g5lkl"))))
+ (base32 "186sgkpggy50gs2pa2p22zppl57xgfhpmja5l13xiskv44iw6x7v"))))
(build-system python-build-system)
(inputs
(list ta-lib))
@@ -2322,7 +2317,7 @@ and manipulation.")
(define-public xmrig
(package
(name "xmrig")
- (version "6.21.2")
+ (version "6.22.0")
(source
(origin
(method git-fetch)
@@ -2330,7 +2325,7 @@ and manipulation.")
(url "https://github.com/xmrig/xmrig")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "0rxnrn92v2w9f0zyv4zchilnrc3wa8nw4d4b4isaxx411zxgds6i"))
+ (sha256 (base32 "1h3qcs176xbfs1k2silr5rf13y0nag6qgsaz14qi3nrxxc0d8n4h"))
(modules '((guix build utils)))
(snippet
;; TODO: Try to use system libraries instead of bundled ones in
@@ -2379,7 +2374,7 @@ mining.")
(define-public p2pool
(package
(name "p2pool")
- (version "3.10")
+ (version "4.1")
(source
(origin
(method git-fetch)
@@ -2388,7 +2383,7 @@ mining.")
(commit (string-append "v" version))
(recursive? #t)))
(file-name (git-file-name name version))
- (sha256 (base32 "0lp9slfwaq3wp4x6xpsiazam5lv6dz57m20adzlzzk0anb1ascr0"))
+ (sha256 (base32 "1ijj3ci0kx87yjv29c6p9wqj15aij7r87sdbjwhzcmbdf46krj3q"))
(modules '((guix build utils)))
(snippet
#~(for-each delete-file-recursively
@@ -2397,10 +2392,11 @@ mining.")
"external/src/curl"
"external/src/libuv"
"external/src/libzmq"
- "external/src/rapidjson")))))
+ "external/src/rapidjson"
+ "external/src/robin-hood-hashing")))))
(build-system cmake-build-system)
(inputs
- (list cppzmq curl gss libuv rapidjson zeromq))
+ (list cppzmq curl gss libuv rapidjson robin-hood-hashing zeromq))
(arguments
(list ; FIXME: Linking fails when LTO is activated.
#:configure-flags #~(list "-DWITH_LTO=OFF")
@@ -2411,7 +2407,7 @@ mining.")
(when tests?
(mkdir-p "tests")
(chdir "tests")
- (invoke "cmake" "../../source/tests")
+ (invoke "cmake" "-DWITH_LTO=OFF" "../../source/tests")
(invoke "make" "-j" (number->string (parallel-job-count)))
(invoke "gzip" "-d" "sidechain_dump.dat.gz")
(invoke "gzip" "-d" "sidechain_dump_mini.dat.gz")
2020-10-04cuirass: Add hurd-manifest.Jan (janneke) Nieuwenhuizen * build-aux/cuirass/hurd-manifest.scm: New file. 2020-10-01ci: Add log and outputs keys.Mathieu Othacehe Add 'log and 'outputs properties to hydra objects. This way Cuirass won't have to go through every derivation to add those properties. * gnu/ci.scm (package->alist, image-jobs, system-test-jobs, tarball-jobs): Add 'log and 'outputs properties. * build-aux/hydra/guix-modular.scm (build-job): Ditto. 2020-10-01ci: Add nix-name and system keys.Mathieu Othacehe Add 'nix-name and 'system properties to hydra objects. This way Cuirass won't have to go through every derivation to add those properties. * gnu/ci.scm (package->alist, image-jobs, system-test-jobs, tarball-jobs): Add 'nix-name and 'system properties. * build-aux/hydra/guix-modular.scm (build-job): Ditto. 2020-08-29build: Remove references to the 'nix-hash' program.Ludovic Courtès * configure.ac: Remove check for 'nix-hash'. * tests/base32.scm (%nix-hash, %have-nix-hash?): Remove. ("sha256 & bytevector->nix-base32-string"): Remove test. * build-aux/pre-inst-env.in: Do not set 'NIX_HASH' environment variable. 2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config).Mathieu Othacehe * Makefile.am (MODULES): Remove guix/zlib.scm and guix/lzlib.scm, (SCM_TESTS): remove tests/zlib.scm, tests/lzlib.scm. * build-aux/build-self.scm (make-config.scm): Remove unused %libz variable. * configure.ac: Remove LIBZ and LIBLZ variables and check instead for Guile-zlib and Guile-lzlib. * doc/guix.texi ("Requirements"): Remove zlib requirement and add Guile-zlib and Guile-lzlib instead. * gnu/packages/package-management.scm (guix)[native-inputs]: Add "guile-zlib" and "guile-lzlib", [inputs]: remove "zlib" and "lzlib", [propagated-inputs]: ditto, [arguments]: add "guile-zlib" and "guile-lzlib" to Guile load path. * guix/config.scm.in (%libz, %liblz): Remove them. * guix/lzlib.scm: Remove it. * guix/man-db.scm: Use (zlib) instead of (guix zlib). * guix/profiles.scm (manual-database): Do not stub (guix config) in imported modules list, instead add "guile-zlib" to the extension list. * guix/scripts/publish.scm: Use (zlib) instead of (guix zlib) and (lzlib) instead of (guix lzlib), (string->compression-type, effective-compression): do not check for zlib and lzlib availability. * guix/scripts/substitute.scm (%compression-methods): Do not check for lzlib availability. * guix/self.scm (specification->package): Add "guile-zlib" and "guile-lzlib" and remove "zlib" and "lzlib", (compiled-guix): remove "zlib" and "lzlib" arguments and add guile-zlib and guile-lzlib to the dependencies, also do not pass "zlib" and "lzlib" to "make-config.scm" procedure, (make-config.scm): remove "zlib" and "lzlib" arguments as well as %libz and %liblz variables. * guix/utils.scm (lzip-port): Use (lzlib) instead of (guix lzlib) and do not check for lzlib availability. * guix/zlib.scm: Remove it. * m4/guix.m4 (GUIX_LIBZ_LIBDIR, GUIX_LIBLZ_FILE_NAME): Remove them. * tests/lzlib.scm: Use (zlib) instead of (guix zlib) and (lzlib) instead of (guix lzlib), and do not check for zlib and lzlib availability. * tests/publish.scm: Ditto. * tests/substitute.scm: Do not check for lzlib availability. * tests/utils.scm: Ditto. * tests/zlib.scm: Remove it. 2020-07-11maint: Remove 'build-aux/git-authenticate.scm'.Ludovic Courtès * Makefile.am (channel_intro_commit, channel_intro_signer): New variables. (authenticate): Use it. (EXTRA_DIST): Remove 'build-aux/git-authenticate.scm'. * build-aux/git-authenticate.scm: Remove.