aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index f10d56ec3f..b98a838f43 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -619,17 +619,7 @@ from a mounted file system.")
"not test_fsck and "
"not test_list and "
"not test_list_inodes and "
- "not test_list_dirent")))))
- (add-after 'install 'patch-shell-wrappers
- ;; These are overcomplicated wrappers that invoke readlink(1)
- ;; to exec the appropriate bcachefs(8) subcommand. We can
- ;; simply patch in the latter file name directly, and do.
- (lambda _
- (let ((sbin/ (string-append #$output "/sbin/")))
- (substitute* (find-files sbin/ (lambda (file stat)
- (not (elf-file? file))))
- (("SDIR=.*") "")
- (("\\$\\{SDIR.*}/") sbin/))))))))
+ "not test_list_dirent"))))))))
(native-inputs
(cons* pkg-config
;; For generating documentation with rst2man.