aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e0f7199d2e..85f603dc06 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1089,7 +1089,7 @@ Emacs).")
(define-public kicad
(package
(name "kicad")
- (version "7.0.6")
+ (version "7.0.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1097,7 +1097,7 @@ Emacs).")
(commit version)))
(sha256
(base32
- "1bifg73id0grn37a4n5wpq440z9xz14q0fvkva5vajx0xfd34llv"))
+ "1xbzf29rhqh6kl0vggdn2dblgp927096fc1lr3y4yw63b8n0qq50"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -1197,7 +1197,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(file-name (git-file-name name version))
(sha256
(base32
- "0byvm25jw108h808g5zdjq14gx4xxd87pvlbczd07c3rx6nmzl08"))))
+ "00f51rcnki08x2jkyla5vmqx7nhck3cyz86wiy0qkmc8klb1a6ba"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_FORMATS=html")
@@ -1231,7 +1231,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(file-name (git-file-name name version))
(sha256
(base32
- "0p60dvig7xx8svzsgp871r0aix2m95bmzg3snz372nmgnza2nnvf"))))
+ "1wr754m4ykidds3i14gqhvyrj3mbkchp2hkfnr0rjsdaqf4zmqdf"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; no tests exist
@@ -1260,7 +1260,7 @@ libraries.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fqnviaxsai0xwyq8xq5ks26j4vd390ns6h6lr0fx2ikv1ghaml5"))))
+ "0xnnivlqgcyaz9qay73p43jnvmvshp2b3fbh3569j7rmgi5pn8x0"))))
(synopsis "Official KiCad footprint libraries")
(description "This package contains the official KiCad footprint libraries.")))
@@ -1277,7 +1277,7 @@ libraries.")
(file-name (git-file-name name version))
(sha256
(base32
- "0dmssyhqd94d9wj8w7g7xjan560b2rwcs540sgl0rc77cw2jify8"))))
+ "141r5wd8s1bgyf77kvb9q14cpsiwwv4zmfzwbgcd42rflsk2lcbc"))))
(synopsis "Official KiCad 3D model libraries")
(description "This package contains the official KiCad 3D model libraries.")))
@@ -3223,7 +3223,7 @@ data structures and to operate on them.")
gerbv
glibmm
gtkmm-2
- librsvg))
+ (librsvg-for-system)))
(native-inputs
(list autoconf automake libtool pkg-config))
(home-page "https://github.com/pcb2gcode/pcb2gcode")
@@ -4214,7 +4214,7 @@ form, numpad.
(define-public rizin
(package
(name "rizin")
- (version "0.5.2")
+ (version "0.6.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4222,7 +4222,7 @@ form, numpad.
version "/rizin-src-v" version ".tar.xz"))
(sha256
(base32
- "18zca3iwdif200wiivm065fs0a5g520q6380205cijca7ky81avi"))))
+ "14bcmjx64pgi9zj4zb7yppx69l1ykjwgf2q41s5672m7z354f1kn"))))
(build-system meson-build-system)
(arguments
(list
@@ -4250,13 +4250,10 @@ form, numpad.
(lambda _
;; Skip integration tests, which require prebuilt binaries at:
;; <https://github.com/rizinorg/rizin-testbins>.
- ;; And 2 of them are failing, reported upstream:
- ;; <https://github.com/rizinorg/rizin/issues/2905>.
(substitute* "test/meson.build"
(("subdir\\('integration'\\)") ""))
;;; Skip failing tests.
(substitute* "test/unit/meson.build"
- (("'analysis_var',\n") "")
(("'bin_mach0',\n") "")
(("'hash',\n") "")))))))
(native-inputs (list pkg-config))