aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm33
1 files changed, 27 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 85f603dc06..ab9a15c752 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1557,6 +1557,27 @@ send break and throttle transmission speed.")
(home-page "https://github.com/wentasah/sterm")
(license license:gpl3+)))
+(define-public libmodbus
+ (package
+ (name "libmodbus")
+ (version "3.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stephane/libmodbus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nbpk1n56kclab8fl32dxi46v2bwax3gfk1zkc796srm7vj42sbv"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Library for the Modbus protocol")
+ (description "@code{libmodbus} is a library to send/receive data with a
+device which respects the Modbus protocol. This library can use a serial port
+or an Ethernet connection.")
+ (home-page "https://libmodbus.org/")
+ (license license:lgpl2.1+)))
(define-public harminv
(package
(name "harminv")
@@ -1974,7 +1995,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
(package
(name "libngspice")
- (version "40")
+ (version "41")
(source
(origin
(method url-fetch)
@@ -1985,7 +2006,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"old-releases/" version
"/ngspice-" version ".tar.gz")))
(sha256
- (base32 "03c9irc44msdpqhbn2fhvb4g0sry8a2qgxl4mbbf557mq1xwl0z3"))))
+ (base32 "1i78im03kx6vp5yml0fiwvqnic8qhczl1893n8zc6l1gblwikqhw"))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -2730,7 +2751,7 @@ comments.")))
(define-public freecad
(package
(name "freecad")
- (version "0.21.0")
+ (version "0.21.1")
(source
(origin
(method git-fetch)
@@ -2739,7 +2760,7 @@ comments.")))
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1i1wv3swnnimmn3kwphb2fcmsc64z96rcg7fhfsgqxcbyrygw6w7"))))
+ (base32 "0qwh6b1s432j5piwgfkphvz0slmxf0m8m8pdr3ny9zna9mghz42k"))))
(build-system qt-build-system)
(native-inputs
(list doxygen
@@ -3113,13 +3134,13 @@ program that can perform mesh processing tasks in batch mode, without a GUI.")
(define-public poke
(package
(name "poke")
- (version "3.2")
+ (version "3.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/poke/poke-" version
".tar.gz"))
(sha256
- (base32 "15qd9z3wv7jrdlh6f9hwgni54ssdz8hzrn4lxiacwv1sslfmb3km"))
+ (base32 "0vlm9xcr7rrfli2x4hi2q41nh8vjd2izpz4zd0xwhqshx2flb000"))
(modules '((guix build utils)))
(snippet
'(begin