aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 266013f45a..2e1ffa1355 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -427,16 +427,16 @@ optimizer; and it can produce photorealistic and design review images.")
(define-public pcb-rnd
(package (inherit pcb)
(name "pcb-rnd")
- (version "2.2.3")
+ (version "2.2.4")
(source (origin
(method url-fetch)
(uri (string-append "http://repo.hu/projects/pcb-rnd/releases/"
"pcb-rnd-" version ".tar.gz"))
(sha256
(base32
- "0j650498d87b4xsggzc0xlk73k0hhj43wfy45qz2lcn0xc3bks1m"))))
+ "06ylc2rd4yvzp3krk62q9dbi13h0yq1x257fbjkh10vfjn0ga5c2"))))
(arguments
- `(#:tests? #f ; no check target
+ `(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'cc-is-gcc
-system gnu) #:use-module (guix git-download) #:use-module (gnu packages autotools) #:use-module (gnu packages c) #:use-module (gnu packages flex) #:use-module (gnu packages fontutils) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public lesstif (package (name "lesstif") (version "0.95.2") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/lesstif/lesstif/" version "/lesstif-" version ".tar.bz2")) (sha256 (base32 "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb")))) (build-system gnu-build-system) (propagated-inputs (list printproto)) (inputs (list libxext libxt)) (home-page "https://lesstif.sourceforge.net/") (synopsis "Clone of the Motif toolkit for the X window system") (description "Clone of the Motif toolkit for the X window system.") (license license:gpl2+))) ; some files are lgpl2.1+ or x11 (define-public motif ;; This commit is from September 2021 and v2.3.8 from 2017. (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed") (revision "0")) (package (name "motif") (version (git-version "2.3.8" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://git.code.sf.net/p/motif/code") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m")))) (build-system gnu-build-system) (inputs (list libx11 xorgproto)) (propagated-inputs (list fontconfig freetype libxext libxft libxpm libxt xbitmaps)) (native-inputs (list autoconf automake byacc flex libtool pkg-config)) (home-page "https://motif.ics.com/motif") (synopsis "Motif toolkit for the X window system") (description "Motif is a standard graphical user interface, (as defined by the IEEE 1295 specification), used on more than 200 hardware and software platforms. It provides application developers, end users, and system vendors with a widely used environment for standardizing application presentation on a wide range of platforms.") (license license:lgpl2.1+))))