aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3e6a2b5df4..95c8d9b756 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1283,6 +1283,28 @@ strings.")
files and directories.")
(license license:gpl3+)))
+(define-public emacs-el-mock
+ (package
+ (name "emacs-el-mock")
+ (version "1.25.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rejeep/el-mock.el/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16xw94n58xxn3zvgyj72bmzs0k5lkvswjmzs79ws9n7rzdivb38b"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/rejeep/el-mock.el")
+ (synopsis "Tiny mock and stub framework in Emacs Lisp")
+ (description
+ "Emacs Lisp Mock is a library for mocking and stubbing using readable
+syntax. Most commonly Emacs Lisp Mock is used in conjunction with Emacs Lisp
+Expectations, but it can be used in other contexts.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")