aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index c3a27cb113..8b0d669587 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -678,3 +679,21 @@ format documents, with the following features:
@item handling encrypted documents
@end itemize\n")
(license license:lgpl3+)))
+
+(define-public python-ebooklib
+ (package
+ (name "python-ebooklib")
+ (version "0.17.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "EbookLib" version))
+ (sha256
+ (base32
+ "1w972g0kmh9cdxf3kjr7v4k99wvv4lxv3rxkip39c08550nf48zy"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-lxml python-six))
+ (home-page "https://github.com/aerkalov/ebooklib")
+ (synopsis "Ebook library which can handle EPUB2/EPUB3 and Kindle format")
+ (description
+ "Ebook library which can handle EPUB2/EPUB3 and Kindle format.")
+ (license license:agpl3+)))